Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using a lyx package to make footnotes in a XeTeX document that compiles to a PDF.

The package is:

#\DeclareLyXModule{Bigfoot}
#DescriptionBegin
#Adds some additional footnote insets. Based upon the bigfoot package.
#DescriptionEnd

Format 11

InsetLayout Custom:RoemischeFussnote
        LyXType         custom
        LatexName       footnoteR
        LatexType       command
        Decoration      classic
        Font
                Size    Small
        EndFont
        MultiPar        true
        LabelString     "Roemische Fussnote"
        Preamble
        \usepackage[]{bigfoot}
        \usepackage[multiple]{footmisc}               
        \DeclareNewFootnote{R}[Roman]
                \MakeSorted{footnoteR}
        EndPreamble
End

The document has globally a line spacing of 1.5 and uses the KOMA-Script class scrbook.

Now my problem is that the footnotes look extremely ugly: They have a spacing of 1 line between different footnotes, but a long footnote that extends to the next line has a line spacing of 1.5 in the paragraph.

Two questions:

  1. How can I set a linespacing of 1 for the complete footnote apparatus?

  2. How can I achieve that different footnotes can share a line and do not get their own line in the footnote apparatus of the page? (some footnotes are very short and it looks quite silly the way it is now.

share|improve this question

closed as unclear what you're asking by egreg, yo', Joseph Wright Sep 9 '13 at 17:58

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I don’t use LyX, so a minimal working example (MWE) would be nice. But I would remove footmisc and use the according KOMA-Script option footnotes=multiple. Question 2 is a RTFM of bigfoot documentation. –  Speravir Nov 1 '12 at 22:53
    
There is no need to shout RTFM at me. I have explained my case and I believe that the difficulties originate from incompatibilities between bigfoot, footmisc, koma-script and possibly LyX. And this incompatibility is NOT covered by all respective manuals! What I have learned so far is that I should not use LyX. –  juri Nov 2 '12 at 0:02
1  
@Juri: I've never heard that one can use packages of LyX in LaTeX. I know you can use LaTeX in LyX (uses another notation). With KOMA-Script be careful with package bigfoot -- as I remember is there a problem. A MWE that shows you you configured your footnotes and shows the quite silly look would be very helpful. –  Kurt Nov 2 '12 at 0:41
    
@juri: Once again in other words (“RTFM” is not shouting, it’s simply an abbreviation). In the bigfoot documentation I can see an option para, which I miss in your LyXModule. And try out a run without footmisc. –  Speravir Nov 2 '12 at 1:22
    
As an info: LyX calls the latex/xetex compilers invisibly to the end user. Obviously it produces latex (or XeTex) code before doing that. A Lyx package defines which latex code will be inserted to the latex source code. It is not itself valid latex code, but a meta-script. I showed it, so that you know how my latex code it generated. I will prepare a MWE so that you can follow more easily without having to read the documentation of lyx. –  juri Nov 2 '12 at 5:56