TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to use a Makefile to compile latex files within vim (and update the view of my current pdf file within my favourite viewer). Here is a little example (I'd like to expand that lateron):

default: pdf
    open brief.pdf &

pdf: brief.tex
    pdflatex -shell-escape -interaction=nonstopmode -file-line-error brief.tex

Calling make from the console or using :!make from within vim works fine. But when I use the build-in :make it fails

 This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012)
 restricted \write18 enabled.

and does not stop at that point. I want to make you of the features of the build-in make to jump to potential errors directly. I'm using MacOS 10.7.5. (not sure if this has anything to do with this).

share|improve this question
Looks like your makeprg might be set to something else? what does :set makeprg? show? – Thruston Nov 2 '12 at 18:57
makeprg=latex -interaction=nonstopmode $* – joachim Nov 2 '12 at 19:14
This looks like the plugin latex-suite is installed which sets makeprg. You have to overwrite the setting. see following stackoverflow question – Hotschke May 30 '14 at 11:50
up vote 1 down vote accepted

As the comment to your question implies the setting of your makeprg variable is not set to make but to a call to LaTeX. That call to LaTeX is not working. I replicated your error by setting my makeprg to what you reported.

If you set your makeprg variable to make it should work.

Without knowing more about your VIM setup I can't tell you why your makeprg is set that way. Perhaps you have some plugin installed that sets it to this for you.

My environment is OSX 10.8.2 with VIM 7.3 with no TeX/LaTeX plugins installed.

Good luck.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.