Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

The problem I'm having is that my second subsubsection is being indented. Probably something which is being done automatically. However, I'm new to LaTeX and don't have a clue how to fix it, so can someone please tell me how to. Below I have reproduced the problem but removed the text I wrote. I know the formatting might look a bit weird on the first page(the footnote), but it's okay with the original text I have so please ignore that.

To clarify: I want NO indention on the second subsubsection which has the text "Brief History of Computer Simulation". Thank you.

\documentclass[12pt,a4paper,oneside]{article}

\begin{document}

\begin{center}
\section*{Simulation Techniques}
\end{center}

\vspace*{12mm}
\subsubsection*{Introduction}
\vspace*{2mm}

Text bla bla text here bla bla

\begin{center}
"bla bla" 
\footnote{url bla bla}
\end{center}

\noindent More text here bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla

\noindent bla bla bla even more text \pagebreak
%---------------Page 2------------------
\subsubsection*{ Brief History of Computer Simulation}
\vspace*{3mm}
The first..
\end{document}

Furthermore, If you see anything that you discourage or anything that might cause me problems in the future please let me know. Thank you.

share|improve this question

closed as too localized by egreg, lockstep, Andrew Swann, Thorsten, percusse Nov 3 '12 at 16:49

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

3  
There are many things I wouldn't recommend: explicit spacings should be avoided as much as possible. Look at the titlesec package for redefining section titles so that just \section will give centering and the desired spacings. However, the problem seems to be in the space between the brace and the "B". –  egreg Nov 3 '12 at 15:36
    
Yes I just realised. Should've had a closer look! But thanks for the reference. Will definitely have a look. –  D.Singh Nov 3 '12 at 15:40
    
One more question, how do I make the top section appear further up the page i.e. making the padded space at the top margin less, as I feel the section stands quite low on the page? –  D.Singh Nov 3 '12 at 15:43
add comment

1 Answer 1

up vote 3 down vote accepted

Suppress the spurious blank space; instead of

\subsubsection*{ Brief History of Computer Simulation}

use

\subsubsection*{Brief History of Computer Simulation}

Also, to format the sectional units, you can use the titlesec package to avoid manual changes:

\documentclass[12pt,a4paper,oneside]{article}
\usepackage{titlesec}

\titleformat{\section}
  {\normalfont\Large\bfseries\filcenter}{\thesection}{1em}{}
\titlespacing*{\section}
  {0pt}{4.5ex plus 1ex minus .2ex}{3.3ex plus .2ex}
\titlespacing*{\subsection}
  {0pt}{4.25ex plus 1ex minus .2ex}{2.5ex plus .2ex}

\begin{document}

\section*{Simulation Techniques}

\subsubsection*{Introduction}

Text bla bla text here bla bla

\begin{center}
"bla bla" 
\footnote{url bla bla}
\end{center}

\noindent More text here bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla

\noindent bla bla bla even more text \pagebreak

\subsubsection*{ Brief History of Computer Simulation}

The first..
\end{document}

If you want to suppress the paragraph indentation for all the document, you can consider using the parskip package:

\usepackage{parskip}

or switching to the scrartcl document class from the KOMA-Script bundle and using one of the parskip options it provides; i.e.,

\documentclass[parskip=half+]{scrartcl}
share|improve this answer
    
Oh god. How did I miss that. Sorry for such a trivial error. I'm completely new to this. –  D.Singh Nov 3 '12 at 15:39
1  
@Jatt I've added some more recommendations to my answer. –  Gonzalo Medina Nov 3 '12 at 15:59
    
Thanks a lot! Really helpful –  D.Singh Nov 3 '12 at 16:01
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.