Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to follow workflow from BEAMER manual (ref. 21.2.2). I want to use the same TeX code to produce both presentation and article. So, I have created three files as advised: main.tex, main.beamer.tex, main.article.tex. I am able to compile article but I fail to do a correct presentation.

LaTeX code \maketitle just simply doesn't work in main.beamer.tex. Have a look at the code: main.tex

\usepackage[T1,T2A]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[russian]{babel}
\usepackage{graphics}

\usetheme{Warsaw}
\setbeamercovered{transparent}

\begin{document}

\title[Свободные ГИС]{Свободные ГИС}
\subtitle{опыт применения}
\author[Владимир Наумов]{Владимир Наумов}
\institute{Консалтинговый центр}
\date{\today}

% [1] Первый титульный слайд
\begin{frame}
\maketitle
\end{frame}

%\beamerdefaultoverlayspecification{<+->}

% [2] Слайд с содержанием доклада (актуально если доклад больше 10-15 минут)
\begin{frame}
\frametitle{О чём этот доклад}
\tableofcontents
\end{frame}
\end{document}
Оценка воздействия на окружающую среду (ОВОС) - выявление, анализ и учет прямых, косвенных и иных последствий воздействия на окружающую среду планируемой хозяйственной и иной деятельности в целях принятия решения о возможности или невозможности ее осуществления.

main.beamer.tex

%\documentclass{beamer}
\documentclass[ignorenonframetext]{beamer}
%\beamertemplatenavigationsymbolsempty
\input{main.tex}

When I run pdflatex with edited main.beamer.tex (documentclass without ignorenonframetext option) it works well.

The option ignorenonframetext should ignore only text outside frames, as far as I know. But in my case it also ignores the text intended for the title frame.

What is the reason that beamer (with ignorenonframetext option) suppresses the text usually made with \maketitle command?

share|improve this question
1  
The reason is that with the option, beamer ignores everything after \begin{document} which is not inside a frame. Put \begin{document} after the declarations of \title, \author and so on. –  egreg Nov 3 '12 at 18:56
    
@egreg thanks! It works. –  Vladimir Nov 3 '12 at 19:01
add comment

1 Answer

up vote 3 down vote accepted

The reason is that with the option, beamer ignores everything after \begin{document} that is not inside a frame.

Put \begin{document} after the declarations of \title, \author and so on; this works also in all standard classes.

\usepackage[T1,T2A]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[russian]{babel}
\usepackage{graphics}

\usetheme{Warsaw}
\setbeamercovered{transparent}

\title[Свободные ГИС]{Свободные ГИС}
\subtitle{опыт применения}
\author[Владимир Наумов]{Владимир Наумов}
\institute{Консалтинговый центр}
\date{\today}

\begin{document}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.