Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm currently writing a research paper and want to manage my bibliography with biblatex. Everything is working fine except a minor annoyance:

Whenever I use the \footfullcite[pagenumber]{key} command there is no space between the full citation and the page number in the postnote.

I uploaded a minimal example here

Is there any way to solve this?

EDIT BY LOCKSTEP: Here's a boiled-down example that still shows the issue:

\documentclass{article}

\usepackage[style=authortitle]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@BOOK{test,
  title = {The Infamous Test},
  publisher = {Testington Test},
  year = {2007},
  author = {John Doe},
  address = {Testville},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

\null\vfill% just for the example

Postnote spacing/punctuation doesn't work for \verb|\footfullcite|,\footfullcite[1-10]{test}
although everything is correct for \verb|\footcite|.\footcite[1-10]{test}

\printbibliography

\end{document}
share|improve this question
2  
Welcome to TeX.sx!. Rather than a link to a ZIP file, it's preferred that the minimal example is spelled out in the question. –  egreg Nov 4 '12 at 15:23
    
Okay, thanks for the info! –  Timm Nov 4 '12 at 15:26
    
Can you tell more about your setting? What version of biblatex are you using? –  egreg Nov 4 '12 at 15:48
    
I'm using MiKTeX 2.9 and the bundled biber backend in the newest version (Version: 4689, Date: 11/2/2012). –  Timm Nov 4 '12 at 16:02
1  
It's related to \finentry. At some point after 1.7 \blx@initunit was uncommented in the definition of \blx@finentry@usedrv. Not sure why. Using \protected\def\blx@finentry@usedrv{\unspace} should fix the issue. –  Audrey Nov 4 '12 at 16:20
show 2 more comments

1 Answer

up vote 3 down vote accepted

The missing postnote delimiter is due to a bug in the \finentry definition for \usedriver. For now add the following to your preamble:

\makeatletter
\protected\def\blx@finentry@usedrv{\blx@setunit\relax}
\makeatother

The above macro has been revised a few times to address problems with whitespace and punctuation. If problems with the new definition arise, please feel free to reopen this issue at the github repo.

share|improve this answer
    
Thanks! That fixed it! –  Timm Nov 4 '12 at 16:33
    
@Timm No problem. Thanks for pointing out this issue. –  Audrey Nov 4 '12 at 16:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.