Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I would like that my full name in the CV appears in a single line, I am using \firstname{manuel} \familyname{fernandez-perez} also my email is too long and it automatically splits it in two lines and I would still want one, I am using \email{} thanks

share|improve this question
    
Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. –  percusse Nov 4 '12 at 20:55
    
I am using the template.tex in ctan.org/tex-archive/macros/latex/contrib/moderncv/examples (with the variation of green, classic) –  inquisitor Nov 4 '12 at 21:03
    
This question is improved at the next question: tex.stackexchange.com/questions/82167/… , which leads to a better result. –  strpeter Oct 8 '13 at 14:05

1 Answer 1

up vote 7 down vote accepted

To solve the first problem you can change \makecvtitlenamewidth (default=10cm) and/or reduce the font size used for the name (the example below uses both changes); for the second issue, to avoid a possible overlap between the name and the personal information, instead of using \email, I used the \extrainfo field, but with the necessary provision to make it functional as the original \email field:

\documentclass{moderncv}
\moderncvstyle{classic} 
\moderncvcolor{green}

\setlength{\makecvtitlenamewidth}{12cm}
\renewcommand*{\namefont}{\fontsize{24}{29}\mdseries\upshape}

\firstname{Manuel} 
\familyname{Fern\'andez-P\'erez}
\title{CV}
\address{street and number}{postcode city}
\mobile{+1~(234)~567~890}
\phone{+2~(345)~678~901}
\fax{+3~(456)~789~012}
\homepage{www.johndoe.com}
\extrainfo{\emailsymbol\emaillink{manuel@fernandez-perez-galdos.com}}

\begin{document}

\makecvtitle
\section{Education}
\cventry{year--year}{Degree}{Institution}{City}{\textit{Grade}}{Description}  \cventry{year--year}{Degree}{Institution}{City}{\textit{Grade}}{Description}

\end{document}

enter image description here

In a comment, a new request was made to shift the name upwards; the file moderncvstyleclassic.sty, responsible for the classic style settings, uses (in the definition of \makecvtitle) a tabular and a minipage with bottom alignment ([b] in the optional argument) to typeset the name and the personal information, respectively; one option then is to use the etoolbox command to patch \makecvtitle and change [b] to [t] (now that the name has been shifted, using \email is again possible without overlapping):

\documentclass{moderncv}
\usepackage{etoolbox}

\moderncvstyle{classic} 
\moderncvcolor{green}

\patchcmd{\makecvtitle}{[b]}{[t]}{}{}
\patchcmd{\makecvtitle}{[b]}{[t]}{}{}

\setlength{\makecvtitlenamewidth}{12cm}
\renewcommand*{\namefont}{\fontsize{24}{29}\mdseries\upshape}

\firstname{Manuel} 
\familyname{Fern\'andez-P\'erez}
\title{CV}
\address{street and number}{postcode city}
\mobile{+1~(234)~567~890}
\phone{+2~(345)~678~901}
\fax{+3~(456)~789~012}
\email{manuel@fernandez-perez-galdos.com}
\homepage{www.johndoe.com}

\begin{document}

\makecvtitle
\section{Education}
\cventry{year--year}{Degree}{Institution}{City}{\textit{Grade}}{Description}  \cventry{year--year}{Degree}{Institution}{City}{\textit{Grade}}{Description}

\end{document}

enter image description here

The name can then be lowered at will, by using the above modifications and something like

 \firstname{\texorpdfstring{\\[1ex]Manuel}{Manuel}} 
share|improve this answer
    
I have this problem: ! Undefined control sequence 1.3 \moderncvcolor{green} I guess I have to download some package? –  inquisitor Nov 4 '12 at 21:49
1  
@inquisitor seems like your moderncv package is outdated. You can get the newest version from CTAN: moderncv. –  Gonzalo Medina Nov 4 '12 at 22:58
    
Now it works, thanks. How can I do to put the name in the upper left corner? I mean upper than it is now –  inquisitor Nov 4 '12 at 23:42
    
@inquisitor please see my updated answer. –  Gonzalo Medina Nov 5 '12 at 0:06
1  
sorry but I cannot make it to work when I include \photo[64pt]{picture} the picture appears higher up in the right up corner and I would like that the name and personal data to be at the same height –  inquisitor Nov 9 '12 at 12:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.