Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm currently writing my thesis, and I've a problem, because when I print a cite more one time via \footcite command, the author first name is hidden.

But I must print every time the full name of the author.

I've read this post About biblatex repeated citations but I can't solve my problem.

I call biblatex package with these options

\RequirePackage[%
style=verbose-trad2,
backend=biber,
dashed=false,
hyperref,
firstinits=false,
alldates=comp,
abbreviate=false,
idemtracker=false,
opcittracker=false,
language=french%
]{biblatex}

mwe.tex

\documentclass{ownclass}%scrbook base (KOMA)
% Don't forget to parse with biber backend
\title{MWE}
\addbibresource{mwe.bib}
\begin{document}
some text\footcite["quote"][2]{Dupont:2012fk}
\clearpage
some other text on a new page with another reference\footcite[21]{Me:2012uq} and another extract from the previous cite\footcite["quote"][2]{Dupont:2012fk}
My problem: firstnames (Tim \& Jean) aren't printed
\end{document}

ownclass.cls

\NeedsTeXFormat{LaTeX2e}
\ProvidesClass{ownclass}[15/11/2012 v1.0]
\LoadClass[12pt, oneside, a4paper]{book}
\RequirePackage[latin1,applemac,utf8]{inputenc}
\RequirePackage[T1]{fontenc}
\RequirePackage{textcomp}

%Biber backend
\RequirePackage[%
style=verbose-trad2,
backend=biber,
dashed=false,
hyperref,
firstinits=false,
alldates=comp,
abbreviate=false,
idemtracker=false,
opcittracker=false,
language=french%
]{biblatex}

\renewcommand*{\newunitpunct}{\addcomma\space} % ,

%Français
\RequirePackage[francais,frenchb]{babel}

\RequirePackage[babel]{csquotes} % Guillemets
\selectlanguage{french}
\frenchspacing
\FrenchFootnotes

bib entries

@book{Me:2012uq,
    Author = {Me},
    Date-Added = {2012-11-05 23:58:33 +0000},
    Date-Modified = {2012-11-05 23:59:00 +0000},
    Publisher = {SMB},
    Title = {Tex and Biblatex},
    Year = {2012}}

@book{Dupont:2012fk,
    Author = {Dupont, Jean and Burton, Tim},
    Date-Added = {2012-11-05 23:49:22 +0000},
    Date-Modified = {2012-11-05 23:52:46 +0000},
    Publisher = {Publisher},
    Title = {Tintin},
    Year = {2012}}
share|improve this question
2  
Welcome to TeX.sx! Please add a minimal working example (MWE) that illustrates your problem. It is considered a lot better to put in some code that will compile, as it makes it a lot easier for us to copy it into our text editor and work with it, and see exactly what it is you are trying to do. In your case: which document class do you use, which bibliography style ... –  Kurt Nov 5 '12 at 22:10

1 Answer 1

up vote 3 down vote accepted

A possible solution is to redefine the cite:name bib macro with the option to print names with first-last option.

\renewbibmacro*{cite:name}{%
  \printnames[first-last]{labelname}%
  \setunit*{\nametitledelim}}
share|improve this answer
4  
Or just use \DeclareNameAlias{labelname}{first-last}. –  Audrey Nov 6 '12 at 13:58
    
It works, thanks a lot ! –  Annhydrium Nov 6 '12 at 20:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.