Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I’m writing a class file and wish to use Droid Sans and Garamond which is no problem width \usepackage{droidsans} and \usepackage[garamond]{mathdesign}. With my TeX Live 2012 on Mac OS X eveything works like a charm but the client, I’m writing the class for, uses Windows XP, Suse and Ubuntu where TeX can’t find all necessary font files, although droidsans and mathdesign are available.

The question is what do I have to do to make the font available for any user (with an up to date distribution)? I guess there’s nothing I can do directly but I would like to explain in the manual what to do to install the fonts …

Update

Heres a small example.

\documentclass{scrbook}

% simulate class option
\newif\iffonts% to prevent the class
                % loading any font packages
\fontstrue

\iffonts
   \usepackage[T1]{fontenc}
   \usepackage{droidsans}
   \usepackage[garamond]{mathdesign}
\fi

\begin{document}
\chapter{Section one}
Some text
\end{document}

This should be compiled with pdflatex. It qould be great if there’d be a solution for WIndows and Ubuntu (other users can help themselves or use \fontsfalse). One may also use \fontsfalse when using any other machin then pdflatex. The font support must only work with pdflatex.

share|improve this question
    
It depends on the fonts (free or not, type1 font or open true type font?), the OS and the used tex engine. pdflatex needs special packages, lualatex and xelatex should use a open true type font without problems ... Could you provide a MWE to show how you use the fonts? –  Kurt Nov 6 '12 at 1:11
    
@Kurt: I added some text an an example – hope that clarifies my question … –  Tobi Nov 6 '12 at 1:40
    
You didn't specify which font Garamond you use? Is it free? URW-Garamond? Or have you to pay for it? Company? Font name? In your MWE you do not call a package to load the garamond font. Which package you have to load (or to build yourself) depends on the used Garamond font ... –  Kurt Nov 6 '12 at 2:15
    
@kurt: \usepackage[garamond]{mathdesign} uses urw garamond –  wasteofspace Nov 6 '12 at 10:12
    
@wasteofspace: thanks –  Kurt Nov 6 '12 at 13:52

1 Answer 1

up vote 3 down vote accepted

The user has to install the packages mathdesign, droidsans and urw-garamond. The best would be to install the packages with the package manager of the used tex distribution. If not possible he has to follow the installation instructions in the readme files. It would be the best to install the font urw-garamond in a local texmf tree. More hints you can find in question getting-urw-garamond-and-the-license.

With some changes your MWE should then compile:

\documentclass{scrbook}

% simulate class option
\newif\iffonts% to prevent the class
                % loading any font packages
\fontstrue

\iffonts
  \renewcommand{\rmdefault}{ugm}
  \usepackage[T1]{fontenc}
  \usepackage{textcomp}
  \usepackage{droidsans}
  \usepackage[urw-garamond]{mathdesign}
\fi


\begin{document}
\chapter{Section one}
Some text
\end{document}
share|improve this answer
    
Why do I need to change \rmdefault manually, doesn’t mathdesign do it? With TeX Live on Mac OSX it’s obviously not necessary … –  Tobi Nov 6 '12 at 19:53
    
I tried the instruction from the linked question and it works fine for Ubuntu with TEX Live 2012 but not on Win 7 with MikTeX (Error: Trying to make PK font md-gmro8y at 657 DPI... Running miktex-makemf.exe... | miktex-makemf: The md-gmro8y source file could not be found. Running ttf2pk.exe... | miktex-makepk: PK font md-gmro8y could not be created.) –  Tobi Nov 6 '12 at 20:27
    
@Tobi: To be save I would use \rmdefault, if not necceccary, you can coment it of course. Have you tried the actual MiKTeX 2.9? Is the font urw-garamond correct installed? Urw-garamond must be installed by you/the user, because it is not included in MiKTeX. So use a local texmf tree, copy all files as described in the readme and don't forget to run refresh the file name data basis! Seems that MiKTeX did not find some files ... –  Kurt Nov 6 '12 at 20:41
    
I installed a fresh MikTeX a few days ago, so I guess it’s the current version. My first try was to install only the files listet in the linked answer. Then I added the other files. I ran the FNDB update after each try without success. DO you have an idea, why it works an Ubuntu and if I do the same in Win it doesn’t – are MikTeX and TeX Live too different in this case? –  Tobi Nov 6 '12 at 23:25
    
OK … I did it again as explained in the readme file and Garamond works. But droidsans not yet (Error: |miktex-makepk: PK font DroidSans-01 could not be created.|) … –  Tobi Nov 6 '12 at 23:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.