Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

For context, this question was raised by the answer to a previous question.

I'm trying to design a title page for a beamer presentation, although this could be a more general issue. I use the minipage capabilities of the \author command to add a second line with co-authors. When adding vertical space between the lines, using [3mm] gives an error, but \vspace{3mm} works. The error only appears when the inputenc package is loaded with the option utf8x. Using utf8, ansinew, latin1 or latin9 worked fine.

Here is a MWE:

\documentclass{beamer} 
\usetheme{_MWE}

\title[short title]{TITLE TITLE TITLE TITLE TITLE TITLE}
%\author[me]{A. U. Thor \\ [3mm] A. N. Other, J. Bloggs, J. Doe}
\author[me]{A. U. Thor \\ \vspace{3mm} A. N. Other, J. Bloggs, J. Doe}
\institute[my institute]{My Institute}
\date{1.1.2012}

\begin{document}
\maketitle
\end{document}

and the style file:

\ProvidesPackage{beamertheme_MWE}

%\usepackage[utf8]{inputenc}    % most systems, modern linux
\usepackage[utf8x]{inputenc}    % most systems, modern linux
%\usepackage[ansinew]{inputenc}    % Windows
%\usepackage[latin1]{inputenc}    % unix and vms
%\usepackage[latin9]{inputenc}    % newer latin, includes euro sign and fractions

\makeatletter
\def\maketitle{%
\begin{frame}[plain]
{%
 \vspace{10mm}
 \parbox{122mm}%
  {%
   \centering
   {\Large \inserttitle}\\
   \vspace{8mm}
   {\large \insertauthor}\\
   \vspace{10mm}
   {\small \insertinstitute}\\
   \vspace{-5mm}
   {\flushleft
    \hspace{1mm}
    LOGO1
    \hspace{60mm}
    \raisebox{0.5mm}{
        LOGO2
    \hspace{10mm}
    }
  }\\
  \vspace{0mm}
  {
   \parbox{53mm}{\centering \small \insertdate\\
   }
  }
 }
}
\end{frame}
  }
\makeatother
share|improve this question
    
wouldn't you know it... it's probably something to do with this tex.stackexchange.com/questions/13067/utf8x-vs-utf8-inputenc utf8x is apparently obsolete and incompatible with several packages. –  craq Nov 6 '12 at 12:50
    
I think it's not good policy to load inputenc in a package (or Beamer theme): this limits users to what the package wants. The problem, however, is not due to this, but to the fact that utf8x is not fully compatible with beamer. –  egreg Nov 6 '12 at 13:06

1 Answer 1

It's not a good idea putting a call to inputenc in a package: this forces you (or the users of the theme) to have a predetermined encoding of your file. But the theme is independent of UTF-8, as far as I can see, so it's preferable to have the call in the document's preamble.

The problem seems to be involved with the \PrerenderUnicode command of ucs.sty and this means that utf8x and beamer are incompatible, at least in some aspects; the same problem appears when only utf8x is loaded and not your personalized theme.

On the other hand there's no real reason why using utf8x; for Greek support there is the new LGRx suite that makes Greek input possible with the utf8 option to inputenc. For single Unicode characters that aren't covered, you can use newunicodechar to provide a definition.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.