Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have read about passing options to classes in this thread, but do not understand what I'm doing wrong. My class is defined like so, using xkeyval and based on memoir.

\NeedsTeXFormat{LaTeX2e}
\ProvidesClass{myclass}[2010/08/15 v1.0]
%%%%%
\pdfminorversion=5\pdfcompresslevel=9\pdfobjcompresslevel=2
\newif\ifcopyedit\copyeditfalse
\newif\ifdraftdoc\draftdocfalse
\RequirePackage{ifthen}
\RequirePackage{xkeyval}
\DeclareOptionX{copyedit}[true]{\ifthenelse{\equal{#1}{true}}{\copyedittrue}{\copyeditfalse}}
\DeclareOptionX{draft}[true]{\ifthenelse{\equal{#1}{true}}{\draftdoctrue}{\draftdocfalse}}
\DeclareOptionX{10pt}{\PassOptionsToPackage{10pt}{memoir}}
\DeclareOptionX{11pt}{\PassOptionsToPackage{11pt}{memoir}}
\ExecuteOptionsX{11pt}
\ProcessOptionsX
%%%%%%
\LoadClass[openbib,fleqn]{memoir}
\RequirePackage{fixltx2e}

and I call it with this document:

\documentclass[11pt,copyedit=false,draft=false]{myclass}
\begin{document}
    some text
\end{document}

But in the log I see that memoir is still loading the 10pt option:

File: mem10.clo 2008/01/30 v0.3 memoir class 10pt size option

How do I make the 11pt option available to the memoir class?

share|improve this question
add comment

1 Answer

up vote 7 down vote accepted

Use \PassOptionsToClass instead of \PassOptionsToPackage.

share|improve this answer
    
<embarassed> thanks. –  Tim A Nov 7 '12 at 14:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.