Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using MiKTex on Windows 8. Using the simplest tex file would bring about the error.

pdflatex.exe: the memory dump file could not be found.

\documentclass{article}
    \begin{document}
        Hello world.
    \end{document}

I've already tried suggestions in this forum as follows.

  • Start-> MikTeX 2.9 -> Maintenance -> Setting -> Open General tab -> maintenance -> update format -> I got a Permission denied in C:\Users\Kevin\AppData\Local\Temp .
  • Start-> MikTeX 2.9 -> Maintenance -> Package Manager -> Repository -> Synchronize -> I got a Permission denied in C:\CTEX\UserData\miktex\somewhere

Is is a permission problem in Windows 8?

share|improve this question
1  
Restart your computer and try again. I know it may sound like a non-solution, but have you tried it? Give some feedback as to whether that resolved the problem or not. –  Werner Nov 7 '12 at 3:40
    
Also Windows 8 is very new. Don’t forget, that many people still running Windows XP, but the most Win users have Windows 7, I guess. In short: If it is specific for Windows 8, all these cannot give help. –  Speravir Nov 7 '12 at 3:47
    
Christian Schenk, the MiKTeX developer, tested about one year ago the preview of Windows 8 and seemed not to have encountered any problems: MiKTeX on Windows 8. So abit more information by you is necessary: Where did you install? Take a look on user permissions because: For me the answer to your question in the moment is “Yes”. –  Speravir Nov 7 '12 at 16:22
    
I tried restart computer as well as reinstalling MiKTeX. It seems the permission issue indeed. I figure it out myself. Hope to help anyone else. –  Kevin Tong Nov 8 '12 at 6:58
    
Same problem occurred to me in windows 7. I actually installed TexStudio and Miktex in F drive. After loading a new windows 7 OS in c drive, I change the path environmental variable and it worked fine. But now showing 'the memory dump file could not be found' error. I tried it in administrator mode, but the same problem is there too. –  user35822 Aug 28 '13 at 3:06

3 Answers 3

Ok. I figured it out my self. It seems that permission is more strict in Windows 8. Or to say the default user is not the administrator.

I change the permission of user group in C:\Users\Kevin\AppData\Local\Temp and C:\CTEX\UserData\miktex\ to full control.

Every thing is sovled


If you want to solve it easily. You could run the text edit ide and MikTex as administrator or close your UAC once and for all.

Less secure is what it takes to get more convenience.

share|improve this answer

It is a permission related to Windows 8. It is not necessary to make the user less secure. Right click on the application you need to run. From the context menu select "Run as Administrator." For instance if you are using TeXnicCenter for compiling your TeX, right click on its shortcut you might have on desktop or Windows 8 apps style alternative and run it as administrator.

Not doing this might create some more complicated errors not easily seen such as "memory dump." They could delete hyperref (bookmarks), bibl data, and so on.

share|improve this answer
    
I am using TeXStudio and this does not fix the problem. –  bb94 Aug 17 at 3:25

I have MikTeX 2.9, and here is what I did to fix this problem on my computer:

  • I gave full control to the installation folder, in addition to the Users****\AppData\Local\Temp folder;
  • Start-> MikTeX 2.9 -> Maintenance -> Package Manager -> Repository -> Synchronize;
  • Try 3 times to compile the Hello World file listed above [1st time yielded a blank pdf; 2nd time, found a missing package; 3rd time was OK]
  • Compiled my file about 5 times, until it stopped finding new "missing" packages. [IMPORTANT: this next step yielded no results until I did the step above]

After all packages were installed, the document finally compiled properly. YAY!

IMPORTANT: Running LaTeX compiler under "Run As Administrator" is NOT an alternative to the steps above. In particular, I still get the same error on my computer when running the compiler under the "Run As Administrator", even when it works fine running as a regular user, without escalation.

Thanks to Kevin Tong for the hint; hope this works for someone else.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.