Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm trying to install the mathdesign package on TeXlive, and running into a slew of issues involving maketexpk and updmap failures. Are there any step-by-step instructions to accomplish this?

Here's what I've done so far:

First, I was trying to use \usepackage[garamond]{mathdesign}, but ran into this problem during a xelatex compile with LaTeX headers:

\documentclass{book}

\usepackage{amssymb,amsmath,amsfonts,fleqn}
\usepackage{theorem}% Bold Math package

\usepackage{xltxtra}
\usepackage{xunicode}
\usepackage{graphicx}
\usepackage{fontspec}
\usepackage[garamond]{mathdesign}

\usepackage[EU1]{fontenc}
\usepackage{bm}% Bold Math package -- install AFTER \usepackage[urw-garamond]{mathdesign}

% bold math and math italic macros

\def\alphab{{\protect\bm{\alpha}}}
\def\Gammab{{\protect\bm{\Gamma}}}
\def\Ab{{\protect\mathbf{A}}}
\def\zerob{{\protect\bm{0}}}
\def\oneb{{\protect\bm{1}}}
\def\Rbmit{{\protect\bm{R}}}
\def\Xbmit{{\protect\bm{X}}}
\def\Ybmit{{\protect\bm{Y}}}
\def\Zbmit{{\protect\bm{Z}}}
\def\Rbbb{{\mathbb{R}}}

\DeclareMathOperator{\tr}{tr}

% http://tex.stackexchange.com/questions/66949/command-nobreakspace-unavailable-when-switching-to-t1-encoding-under-xelatex
\DeclareTextCommandDefault{\nobreakspace}{\leavevmode\nobreak\ } 

\begin{document}

A pretty fact for a square matrix~$\Ab$
and~${t\in\Rbbb}$: \begin{equation} \det e^{\Ab t} =
  e^{t\tr\Ab}.\end{equation} The Riemannian curvature tensor using bold
math italics: \begin{equation} \Rbmit(\Xbmit,\Ybmit)\Zbmit
  =\bigl([\nabla_\Xbmit,\nabla_\Ybmit]-\nabla_{[\Xbmit,\Ybmit]}\bigr)\Zbmit.\end{equation}
The generalized gamma function $\Gammab_\alphab(\Ab)=\zerob$.

\end{document}

Error:

...
LaTeX Font Warning: Font shape `EU1/mdugm/m/sl' undefined
(Font)              using `EU1/mdugm/m/n' instead on input line 42.

[1] (./foo.aux)

LaTeX Font Warning: Some font shapes were not available, defaults substituted.


kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 md-gmr8y
mktexpk: don't know how to create bitmap font for md-gmr8y.
mktexpk: perhaps md-gmr8y is missing from the map file.
kpathsea: Appending font creation commands to missfont.log.

** WARNING ** Could not locate a virtual/physical font for TFM "md-gmr8y".
** WARNING ** >> There are no valid font mapping entry for this font.
** WARNING ** >> Font file name "md-gmr8y" was assumed but failed to locate that font.
** ERROR ** Cannot proceed without .vf or "physical" font for PDF output...

Output file removed.
 )
Error 256 (driver return code) generating output;
file foo.pdf may not be valid.
Transcript written on foo.log.

So I tried to install mathdesign (which has md-gmr8y) into texmf-local by doing the following.

cd ~/Downloads/mathdesign
sudo mkdir /opt/local/share/texmf-local/tex/latex/mathdesign
sudo rsync -va ./latex/ /opt/local/share/texmf-local/tex/latex/mathdesign

sudo rsync -va ./afm/ /opt/local/share/texmf-local/fonts/afm

sudo rsync -va ./opentype/ /opt/local/share/texmf-local/fonts/opentype
sudo rsync -va ./tfm/ /opt/local/share/texmf-local/fonts/tfm
sudo rsync -va ./type1/ /opt/local/share/texmf-local/fonts/type1
sudo rsync -va ./vf/ /opt/local/share/texmf-local/fonts/vf

sudo mkdir -p /opt/local/share/texmf-local/fonts/map/pdftex/mathdesign
sudo rsync -va ./map/ /opt/local/share/texmf-local/fonts/map/pdftex/mathdesign

sudo mkdir -p /opt/local/share/texmf-local/fonts/enc/mathdesign
sudo rsync -va ./enc/ /opt/local/share/texmf-local/fonts/enc/mathdesign

sudo mkdir -p /opt/local/share/texmf-local/dvipdfm/config
sudo rsync -va ./config/ /opt/local/share/texmf-local/dvipdfm/config

sudo vi /opt/local/var/db/texmf/web2c/updmap.cfg
# mathdesign
Map mdput.map
Map mdugm.map
Map mdbch.map
Map mdpus.map
Map mdpga.map
Map mdici.map
sudo mktexlsr
sudo updmap

But this results in the updmap error:

updmap is using the following updmap.cfg files (in precedence order):
  /var/root/.texlive2012/texmf-config/web2c/updmap.cfg
  /opt/local/var/db/texmf/web2c/updmap.cfg
dvips output dir: "/var/root/.texlive2012/texmf-var/fonts/map/dvips/updmap"
pdftex output dir: "/var/root/.texlive2012/texmf-var/fonts/map/pdftex/updmap"
dvipdfmx output dir: "/var/root/.texlive2012/texmf-var/fonts/map/dvipdfmx/updmap"
pxdvi output dir: "/var/root/.texlive2012/texmf-var/fonts/map/pxdvi/updmap"

ERROR:  The following map file(s) couldn't be found:
    mdpga.map (in /opt/local/var/db/texmf/web2c/updmap.cfg)

    Did you run mktexlsr?

    You can disable non-existent map entries using the option
      --syncwithtrees.

I know I put the file mdpga.map in /opt/local/share/texmf-local/fonts/map/pdftex because I can see it there and the results of mktexlsr. Is that where it should go? I'm at a loss for the limited mathdesign installation and updmap documentation.

share|improve this question

closed as too localized by mafp, lockstep, Kurt, Werner, egreg Mar 22 '13 at 16:05

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
You want to load an Open Type Font (you use \setmainfont) but you are not loading fontspec. Only then you can set an OT font! Fontspec also does not require any updmapping. So include \usepackage{fontspec} before \setmainfont. An alternative to mathdesign which requires the proper installation of URW Garamond (not the same as Adobe Garamond!) is the mathastext package. This sets the letters and numbers of the math font to your main text font. –  Jörg Nov 7 '12 at 15:16
    
Thanks, Jörg. That's correct, but not my actual issue. I've edited my post to code that tickles the bug. I'm trying to install a package that will typeset Adobe Garamond with bold math included in the same style. Any idea why updmap fails? –  stvs Nov 7 '12 at 19:27
    
Just a hint, if you want to address someone in a comment use "@username", then we get a notification. –  Jörg Nov 8 '12 at 11:41
    
Regarding your issue, do you need the mdpga at all? I think that's for Pagella (Palatino). Anyway, is the map file suppposed to go into the pdftex folder? On my TeXLive they are in texmf-local\fonts\map\dvips\<fontname>. I still think your objective can be achieved with mathastext. Have you tried that? –  Jörg Nov 8 '12 at 11:45

Browse other questions tagged or ask your own question.