Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Hello everybody out there using TeX,

Sorry for molesting you with a question involving closed-source software, but Adobe's Acrobat Reader on Ubuntu 12.04 doesn't display colored text within my document, whereas evince for example does. Can anyone of you reproduce this minimal example?

\documentclass{article}
\usepackage{color}
\begin{document}
Hello, \color{blue}{world}!
\end{document}
share|improve this question
1  
I can see the colors without any problems (Win 7, Sumatra and AcroRead) Use xcolor it has one more x in it must be better :) –  percusse Nov 7 '12 at 16:34
    
I don't see any problem here : just tried with Okular 0.15.3, Adobe Reader 9.5.1, epdfview 0.1.8 and even PDF Xchange Viewer 2.5 (all under KDE 4.9). Check your install of Adobe Reader (by the way, under Linux you don't really need Adobe reader since there are plenty of good readers). –  rcabane Nov 7 '12 at 16:41
3  
acrobat (windows at least) has an option to replace the document colours in its accessibility options. Are you sure that isn't checked? –  David Carlisle Nov 7 '12 at 16:45
    
why do we need to provide another MWE? –  Please don't touch Nov 7 '12 at 17:04
    
Adjusting the accessibility options indeed solves the problem. I should have read the Acrobat Reader documentation more carefully. –  Penguin Nurse Nov 8 '12 at 8:04

2 Answers 2

Acrobat (windows at least) has an option to replace the document colours in its accessibility options. If this is checked then you can not control the colours from within the pdf file as the reader will replace them with colours chosen to help with colour distinctions.

share|improve this answer

I've had similar problems on Windows when using some alternative fonts. Use \textcolor instead of \color.

\documentclass{article}
\usepackage{color}
\begin{document}
Hello, \textcolor{blue}{world!}
\end{document}

The \def of \textcolor uses \leavevmode. You could try \leavevmode\color{blue} also.

share|improve this answer
    
Trying \textcolor was also my first idea. Unfortunately it didn't work. –  Penguin Nurse Nov 8 '12 at 7:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.