Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I would like to see the non-printable Unicode bidi characters PDF (202C), LRO (202D), RLO (202E) in the emacs editor (but not the pdf output). How can i do this?

EDIT: Here's a minimal working example.


%% -*- mode: LaTeX; coding: utf-8 -*-
\documentclass{article}
\usepackage[utf8x]{inputenc}
\begin{document}
    Forward, [202e]drowkcab[202c] and forward again.
\end{document}

Here [202e] and [202c] stand for the Unicode bidi characters of the corresponding hexadecimal codes, namely RLO (Right-to-Left Override) and PDF (Pop Directional Formatting), respectively. I have entered them using the combinations C-x 8 RET 202e RET and C-x 8 RET 202c RET, respectively. The output reads:

Forward, backward and forward again.

Ideally i would like the characters [202c] and [202e] to show in the emacs editor, but not in the pdf output, as yellow 'C' and 'E', respectively.

share|improve this question

closed as off-topic by Joseph Wright Aug 4 '13 at 16:02

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

    
What document class do you use? Which font do you use? Have you called package ìnputenc`? A MWE would be helpful. –  Kurt Nov 9 '12 at 19:51
    
@Kurt 1. document class = article, 2. font = the default font (how can i tell what the default is?), 3. I have called package 'inputenc' with option 'utfx8', 4. What's MWE? –  Evan Aad Nov 9 '12 at 19:58
    
Follow this link: Please add a minimal working example (MWE) that illustrates your problem. It is considered a lot better to put in some code that will compile, as it makes it a lot easier for us to copy it into our text editor and work with it, and see exactly what it is you are trying to do. –  Kurt Nov 9 '12 at 20:01
    
@Kurt I have added a MWE. –  Evan Aad Nov 9 '12 at 20:22
    
You didn't show how you includes the unicode characters (\char"XXXX) in your document. You could try to create two new commands like \ltr and \rtl and add, if you do not print it, the requested characters in this commands. To print change the commands or use a class option to do it automaticly. –  Kurt Nov 9 '12 at 23:36
show 4 more comments

Browse other questions tagged or ask your own question.