TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The following code fails Option clash for package graphicx, it seems to be an incompatibility between the package graphicx (when the option pdftex is used) and the package tikz.



    The lazy dog...


I am currently working with Debian wheezy (updated as of 10th November 2012), and the latest TeXLive LaTeX distribution included.

Any ideas?

share|improve this question
Welcome to TeX.sx! A tip: If you indent lines by 4 spaces, they'll be marked as a code sample. You can also highlight the code and click the "code" button (with "{}" on it). You don't have to sign with your name since it automatically appears in the lower right corner of your post. – egreg Nov 10 '12 at 11:19
The pdftex option should never be passed to graphicx, which is able to guess it by itself. – egreg Nov 10 '12 at 11:20
TikZ loads graphicx automatically and both know what to do when you choose a driver. – percusse Nov 10 '12 at 11:20
up vote 17 down vote accepted

The tikz package already loaded the graphicx package, so you can't load it again. Trying to load it with different options will cause the "Option clash" error. You can use \PassOptionsToPackage{<options>}{graphicx} before loading tikz to pass any additional options to the internally loaded graphicx. However, you do not need and should not use the pdftex option manually with modern LaTeX distributions. Packages which are driver dependent are very well capable to detect the right driver by themselves and providing a wrong one causes all kinds of trouble.

share|improve this answer
Ok, thank you very much for your answer. I already found out that what you say is correct: I do not need to call {pdftex}{graphicx}, eps figures included are automatically and correctly converted to .pdf by {graphicx}. – Ricardo Nov 15 '12 at 9:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.