Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using Texmaker in my MacBook. Generally for text writing places, Command+ or Command+ takes the cursor to the right or left most position of that line. But I see that when I have already compiled my .tex file (I always quickbuild to create the PDF and see it side by side by turning on the PDF viewer from below) and can see the PDF output on the right, this command is just rotating the output file. Any help? Please let me know if the question is unclear.

share|improve this question
4  
Welcome to TeX.SE. That seems to be a "feature" of the PDF viewer. You need to click back on the source .tex file (to change the focus) to be able to use those commands. –  Peter Grill Nov 12 '12 at 21:21
    
@PeterGrill Looks like an answer to me :-) –  Joseph Wright Nov 13 '12 at 8:02

2 Answers 2

up vote 2 down vote accepted

Based on your description, it appears that Texmaker switches focus to the PDF file upon building, and hence the command shortcuts are being passed to the PDF viewer. You need to click back on the source .tex file in order to return focus back to that window. Subsequent command sequences should apply to the .tex source window.

share|improve this answer
    
Sorry.. if I understood it correctly, it doesn't solve the problem. As long as I can see the pdf on the right side, even though I click on the .tex file, it gives me the same problem. Only if I turn off the pdf viewer, things are back to normal. But, may be I misunderstood something. –  user1349 Nov 13 '12 at 18:30
    
I have downloaded the version of TeXMaker for Mac OS 10.6.8 and the keyboard sequences you describe work for me with the PDF viewer open. If I change focus to the PDF viewer than it rotates exactly as you describe. But if I click on the TeX source code (with the PDF still visible) I can go to the beginning and end of the line using the Command → and Command ←. –  Peter Grill Nov 14 '12 at 10:26
    
I see. May be I am still making some mistakes. Okay, I will think about it. Thanks for all of your help. –  user1349 Nov 14 '12 at 18:40

FYI: it was a bug in 3.5 Version of TexMaker, I had this issue, too. The bug seems to be fixed in 3.5.2 for that I do not recognize the problem anymore - try an update :-)

share|improve this answer
    
Welcome to TeX.sx! –  lockstep Nov 18 '12 at 14:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.