Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using Vim with LaTeX-Suite. Occasionally when I compile a file with errors using <Leader>ll, the error in my source is such that the LaTeX compiler registers an error in a file deep in the bowels of my TeX distribution, say pstricks-add.tex or something, so it automatically opens this irrelevant file in the window.

Since the actual error is in my source, I'd like to surpress this behavior, and only have it open the file when I press Enter after selecting it in the Quickfix window.


Notes:

The proper, erroneous line in my source is displayed in the .log file window below the Quickfix window

I have the following in my .vimrc:

" compile to pdf                              
let g:Tex_DefaultTargetFormat = 'pdf' 

" pdf compile and view settings                                
let g:Tex_ViewRule_pdf = 'open -a Preview'
let g:Tex_CompileRule_pdf = 'latexmk -pdf'

" ignore all warnings below level 4
let g:TCLevel = 4

" one last thing for latex
let g:tex_flavor = 'latex'
share|improve this question

1 Answer 1

up vote 4 down vote accepted

let g:Tex_GotoError=0

in your ~/.vimrc should do pretty much what you want.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.