Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am creating a presentation and along with the presentation (that I am going to show in the class), I am trying to make a student handout. So far, everything is fine. The part I am struggling with is that I would like to hide some parts of the presentation in the handout. Then students are supposed to write down these parts in their handouts during the presentation. One way I can do this (suggested by a friend!) is by changing the color of the "to be hidden" part. Is there any other more systematic way of doing it?


On a simple example it works. But in my document I got into trouble. The only difference between my code and yours is in Preamble. I use

\documentclass [11 pt, xcolor=pdftex,x11names,table]{beamer}     
\documentclass[11 pt, handout,xcolor=pdftex,x11names,table]{beamer}
\usepackage{pgfpages}
\pgfpagesuselayout{2 on 1}[a4paper,border shrink=5mm]
\pgfpageslogicalpageoptions{1}{border code=\pgfusepath{stroke}}
\pgfpageslogicalpageoptions{2}{border code=\pgfusepath{stroke}}

In my code and for handout, I comment the first line and specifically \item<beamer> doesn't work at all. I am using a lot of different packages. I was wondering if any package possibly can create problem. By the way \only<beamer> { ... } works fine and I only have trouble with \item<beamer>

UPDATE: I found the problem! It had problem with \setbeamercovered{transparent=50} after making this line a comment, it worked well

share|improve this question
add comment

1 Answer 1

up vote 6 down vote accepted

This might depend on how you are producing the handout; if you are using the handout class option, then you can use the beamer mode specification for the material that you want only for the presentation and not for the handout. A little example: processing the following simple document as it is:

\documentclass%[handout]%
{beamer}
\mode<beamer>{\usetheme{CambridgeUS}}
%\usepackage{pgfpages}
%\pgfpagesuselayout{2 on 1}[a4paper,border shrink=5mm]

\begin{document}

\begin{frame}
\frametitle{First test frame}
\only<beamer>{Text for the presentation.}
Text for presentation and handout
\begin{itemize}
\item Item for presentation and handout.
\item<beamer> Item for presentation.
\item Another item for presentation and handout.
\end{itemize}
\end{frame}

\begin{frame}
\frametitle<beamer>{Second test frame}
\only<beamer>{Another example text for the presentation.}
Text for presentation and handout
\begin{block}<beamer>{Example block}
Some text in the block
\end{block}
\end{frame}

\end{document} 

you get the full document for the presentation:

enter image description here

Now, to produce the handout you uncomment the relevant parts:

\documentclass[handout]%
{beamer}
\mode<beamer>{\usetheme{CambridgeUS}}
\usepackage{pgfpages}
\pgfpagesuselayout{2 on 1}[a4paper,border shrink=5mm]

\begin{document}

\begin{frame}
\frametitle{First test frame}
\only<beamer>{Text for the presentation.}
Text for presentation and handout
\begin{itemize}
\item Item for presentation and handout.
\item<beamer> Item for presentation.
\item Another item for presentation and handout.
\end{itemize}
\end{frame}

\begin{frame}
\frametitle<beamer>{Second test frame}
\only<beamer>{Another example text for the presentation.}
Text for presentation and handout
\begin{block}<beamer>{Example block}
Some text in the block
\end{block}
\end{frame}

\end{document} 

and now you get a handout document not showing the parts written in beamer mode:

enter image description here

share|improve this answer
    
This is fantastic! Thanks a lot! –  N Nik Nov 15 '12 at 1:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.