Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a huge set of .tex files which compile into a single document. I have recently switched to Kile on Unbuntu (love it so far). However I see that forward search from source files other than the root don't work because Kile doesn't know how they fit into the document as a whole, unless they are included in a Kile project (the error message is ".pdf does not exist; did you compile the source file?").

I assume that creating a Kile project and adding the existing source files is the way to solve this. But how can I do that efficiently? It seems I have to add files in one folder at a time.

Edit: What I really want is to be able to do forward-search in Kile with nested source files. I don't particularly care if I have a Kile project file. How do I do that?

share|improve this question
    
Do you have synctex enabled --synctex=1? –  Peter Grill Nov 16 '12 at 2:37
    
Yes. Using PdfLatex with "Modern" build configuration. –  rmp251 Nov 16 '12 at 2:52
add comment

2 Answers

up vote 2 down vote accepted

Kile does not know about the structure of your project. If you do not explicitly specify a master file, it assumes that the file you are currently editing is the master file and tries to open a PDF file with the same name (and produces the error you are getting).

As a solution, you can either create a Kile project that stores the relationship between your tex files or use the Settings > Define current document as 'Master Document' option.

share|improve this answer
add comment

Had the same problem, but setting the master document property (as Roland W proposed) did not help. Instead, I replaced an input' with aninclude' command in the main document, then jumping from the current cursor position in Kile to the same position in the pdf worked again.

I assume this is a valid solution, as it was the only thing I modified.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.