Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am new to LaTeX and wanted to install the required "programs". But when I came to installing TeX Live, there seemed to be a problem:

Can't spawn "cmd.exe": No such file or directory at (directory)

I have no idea what to do, I simply just downloaded the zipped file from the internet, unzipped it at a random location and tried to run it from cmd.

My PC is recently formatted with Windows 8 and I haven't installed anything with LaTeX before on it. Hope someone can help.

share|improve this question
1  
Welcome to TeX.sx! –  Kurt Nov 19 '12 at 16:36
    
Win 8! good for you:-) –  Vahid Damanafshan Nov 19 '12 at 17:51
    
Have you tried MikTeX, it is not texlive but usually works good on windows systems? –  Martin H Nov 19 '12 at 19:25
    
No, I was just recommended to use this :) –  Joakim Nov 19 '12 at 19:38
2  
add comment

3 Answers 3

I am running TeXLive on Windows 8 x64 and there are no compatibility issues that I can see. Just to double check your procedure:

  • Download install-tl.zip for Windows from CTAN.
  • Extract the ZIP to a destination of your choice, preferably with 7-zip. The extracted folder has 49.9 MB, 2,973 files and 407 folders on my system.
  • Run install-tl.bat by simply double clicking on it.

I did not have to do anything else, as such the installation for me is identical to previous issues. If this does not work try:

  • Rightclick on install-tl.bat
  • Select Run as Administrator

Hope that helps, but I don't see why there should be any issues.

share|improve this answer
    
I’m installing texlive on Windows 7. Running install-t1.bat didn’t work for me (some error on cmd prompt). However, I had more success with running the install-t1-advanced.bat. The installer has a GUI interface showing detail installation process. Thanks for your helpful post. –  EnglishLearner Apr 12 '13 at 19:15
add comment

I had the same problem, seems that the problem is related to the environmental variables in Windows 8. I changed the variable "PATHEXT" (it holds the sequence that Windows looks for executables in) from ".COM;.EXE;.BAT;...." to ".EXE;.BAT;.COM"...., this fixed the problem for me. Environmental variables are found under

Controlpanel>System and security>System>Change settings>Advanced>Environmental variables

(translated from danish).

Happy TeXing!

share|improve this answer
add comment

For me this was also a problem with the PATH-variable.

Go to environmental variables, search for PATH and add at the end: ;C:\Windows\system32. The semicolon is important as it separates the entries.

You can test it by typing cmd into the console. If it works (and you had the same problem like me), tlmgr may now update properly.

Restart the console after changing environmental variables.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.