Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

This is with ref to my previous question Package clash in multilingual report.

\documentclass[11pt,table,a4paper]{article}
\usepackage{lmodern}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}

\usepackage{CJKutf8}
\usepackage[english,russian]{babel}

\newenvironment{SChinese}{%
 \CJKfamily{gbsn}%
 \CJKtilde
 \CJKnospace}{}

 \begin{document}
 \selectlanguage{russian}
  Это мой первый многоязычный докладе.
  Инфантильный гипертрофический стеноз привратника - это серьёзное 
 \selectlanguage{english}
  This is my first multilingual report.

 \begin{CJK}{UTF8}{}
  \begin{SChinese}
    这是我的第一个多语种的报告。
  \end{SChinese}
  \end{CJK}

  \end{document}

when I try to compile it, I get following error message.

LaTeX Warning: Unused global option(s):
    [table].

(./data.aux
(/usr/local/texlive/2011/texmf-dist/tex/latex/cyrillic/t2acmr.fd))
(/usr/local/texlive/2011/texmf-dist/tex/latex/lm/t1lmr.fd)

LaTeX Font Warning: Font shape `T2A/lmr/m/n' undefined (Font)         
using `T2A/cmr/m/n' instead on input line 15.


! Package inputenc Error: Unicode char \u8:  not set up for use with
LaTeX.

See the inputenc package documentation for explanation. Type  H
<return>  for immediate help.  ...                                    

l.18 ...�ный гипертрофический стеноз привра...

How can I avoid such error message.

share|improve this question
1  
Try loading fontenc with \usepackage[T1,T2A]{fontenc}. The T2A option is needed for Russian letters. Also note that lmodern doesn't load any cyrillic characters, hence the name "Latin Modern" (if you didn't already know this). –  user2473 Nov 20 '12 at 4:01
1  
I used \usepackage[T1,T2A]{fontenc} still same error message. –  Manish Nov 20 '12 at 4:04
1  
Your example compiles fine on my machine. I see you're using TeX Live 2011. Something seems to be acting funny with your fonts. I suggest upgrading to an updated version of TeX Live 2012. In the meantime, perhaps removing \usepackage{lmodern} might help? –  user2473 Nov 20 '12 at 4:07
    
I installed Tex Live 2012 and remove lmodern message but i m still getting same error message. –  Manish Nov 20 '12 at 6:11
1  
The problem seems to be in the "no-break space" character. Add \DeclareUnicodeCharacter{00A0}{~} to your preamble. –  egreg Nov 20 '12 at 7:36
show 3 more comments

3 Answers

up vote 18 down vote accepted

The error you get is due to a "no-break space" character, according to what I can gather by copying an pasting your message.

This character is not usually set up by the [utf8] option and it's invisible to many editors, so it can slip in a document without the typist knowing it.

Solution: add in your preamble

\DeclareUnicodeCharacter{00A0}{ }

if you don't mean to type a no-break space, or

\DeclareUnicodeCharacter{00A0}{~}

if you want that the character stands for what its name says.

share|improve this answer
    
Thanks it works for me. –  Manish Nov 20 '12 at 8:03
    
Sorry, I was wrong in my last comment. The fffe I got was put there by the command I used to see the encoding of the pasted text. Anyway, I cannot get the 00A0 either, so I hold my question. How did you came to it? –  JLDiaz Mar 18 '13 at 11:36
    
@JLDiaz Copy paste the error message; the conversion of the char \u8:  not bit gives the following sequence of Unicode points: 0063 0068 0061 0072 0020 005C 0075 0038 003A 00A0 0020 006E 006F 0074, where you clearly see 00A0. –  egreg Mar 18 '13 at 11:36
    
@egreg Thanks. That's what I did, but I got 0020 instead. I guess that my browser was "too smart" when copying characters to the clipboard. I pasted then at several Unicode converters online, and also in a terminal and used xxd, but I got always 0020 for the 00A0 char. –  JLDiaz Mar 18 '13 at 12:29
2  
@nuttyaboutnatty You can use \newunicodechar{^^a0}{~} after loading \usepackage{newunicodechar} –  egreg Jul 8 '13 at 20:51
show 2 more comments

As this is one of the top google hits for this error message, here's a more general answer with an example:

The cause is a unicode character in one of your input files that isn't mapped to an output. This may -- especially if you're using the (unicode-supporting) biblatex/biber system -- be in your bibliography. This is a good place to look for errors as .bib files downloaded from publishers website are often malformed. You can tell if the error comes from the bib file - the line number in the error message will be that of your \end{document}, which makes tracking down the actual error rather tricky (inspecting various aux files doesn't appear to help).

ome of these errors are subtle, like the non-breaking space in the question, or the hyphen (U+2010) character given to me by one journal, which looks identical to the hyphen-minus produced by the keyboard.

Copying the character after the hyphen and searching for it should help - unless your command window or editor "helps" by converting it to the more common equivalent or replacing unicode with blanks - in that case copy it from your .log and search all the input files.

(I'm happy to expand this in response to comments or watch it grow -- it's just an attempt to be helpful to searchers)

share|improve this answer
    
ome, ome, ome ;-) –  Speravir Feb 12 at 16:17
    
I often mistakenly type this character in ViM on Mac OS X by hitting ALT+SHIFT+SPACE, often after writing {\some-command ...}. Thank you for the explanation! –  csl Apr 14 at 18:15
add comment

\usepackage[utf8x]{inputenc}

You must install texlive-latex-extra before use it.

share|improve this answer
1  
Welcome to TeX.sx!. May be you can add which OS ? Ubuntu ? how to install ? –  texenthusiast Mar 18 '13 at 10:36
2  
See tex.stackexchange.com/q/13067/15925 for discussion of utf8x. –  Andrew Swann Mar 18 '13 at 11:05
    
Yes, it's for Ubuntu. –  Evgeny Mar 18 '13 at 18:23
    
Now I get "Unknown Unicode character" –  Geremia Apr 11 at 1:59
    
@Geremia, please show string with this error –  Evgeny Apr 11 at 5:59
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.