Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I've only recently started to work with LaTeX.
I've seen the nice CV that it is possible to do with moderncv, however I'm not able to change the color to purple. I do not understand why..
It works with other colors, blue, orange, etc..

\moderncvtheme[purple]{casual} 

Anyone has any idea how to change to purple or why this is happening?

MWE:

\documentclass[11pt,a4paper]{moderncv}

 % moderncv themes
\moderncvtheme[purple]{casual}
% character encoding
\usepackage[utf8]{inputenc}                   % replace by the encoding you are using
% adjust the page margins
\usepackage[scale=0.8]{geometry}
%\setlength{\hintscolumnwidth}{3cm}  

\firstname{First Name}
\familyname{Family Name}
\title{Curriculum Vitae} 

\begin{document}
\maketitle \\[-4.5em]

\section{Personal details}
\cvline{e-mail}{\small \\[-1.65em]
\cvline{mobile} {\small }\\[-1.65em]
 \cvline{nationality}{\small }\\[-1.65em]
\cvline{date of birth}{\small }\\[-2.5em]

\end{document}
share|improve this question
2  
Welcome to TeX.sx! \moderncvtheme[purple]{casual} works for me, so please add a minimal working example (MWE) that illustrates your problem. –  lockstep Nov 20 '12 at 15:04
    
Thank you! I'm using TexMaker..could it be because of that? The problem is instead of purple I have it in blue.. –  pavid Nov 20 '12 at 15:08
    
Using a certain editor isn't likely to be the cause. –  lockstep Nov 20 '12 at 15:11
add comment

2 Answers

up vote 5 down vote accepted

The purple color option was added in version 0.13.0 of moderncv (released on November 06 2011).

Depending on what LaTeX distribution you are using (yes, I am looking at Ubuntu < 12.10...), you might still be using a very outdated version of moderncv. Please check your .log to find out if that is the cause of your issue, and update moderncv from ctan or launchpad accordingly.

share|improve this answer
    
Thank you! In fact that was the problem, I have ubuntu 12.04, I've updated the moderncv (with some difficulties :p) but now it is working. I even have more templates ;) Thank you for your help –  pavid Nov 21 '12 at 17:24
    
@pavid You're welcome! –  Xavier Nov 21 '12 at 22:16
add comment

Your given MWE works for me (after deleting your several \\[-1.65em]). If I change your line \moderncvtheme[purple]{casual} to \moderncvtheme[blue]{casual} the color in the documents changes.

I think your used pdf viewer does not show the changing of the color. I suggest you store a purple and a blue CV in two pdf files. Then use Acrobat Reader or SumatraPDF to view the CV and you will see the color changing. It could also be that you have to adjust your screen ...

The changed MWE:

%http://tex.stackexchange.com/questions/83528/moderncv-doesnt-work-with-purple
\documentclass[11pt,a4paper]{moderncv}

 % moderncv themes
 \moderncvtheme[purple]{casual} % purple color in CV
%\moderncvtheme[blue]{casual}   % blue color in CV
% character encoding
\usepackage[utf8]{inputenc}                   % replace by the encoding you are using
% adjust the page margins
\usepackage[scale=0.8]{geometry}
%\setlength{\hintscolumnwidth}{3cm}  

\firstname{First name}
\familyname{Family name}
\title{Curriculum Vitae} 

\begin{document}
\maketitle 

\section{Personal details}
\cvline{e-mail}{\small} 
\cvline{mobile}{\small} 
\cvline{nationality}{\small}  
\cvline{date of birth}{\small}

\end{document}
share|improve this answer
    
Thank you for your help. I followed @Xavier suggestion and with the new version of moderncv installed all colors work :) –  pavid Nov 21 '12 at 17:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.