Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have been unable to print handouts --- multiple slides per page with border around each. And it just does not work. I tried compiling with xelatex and latex (both almost default installs on Ubuntu 10.12).

How do I set it right? Below is the MWE.

\documentclass[xcolor=dvipsnames,english,professionalfonts,smaller,handout]{beamer}

\usetheme{Madrid}
\usecolortheme[named=Black]{structure}

\usepackage{arev}
\usepackage{wasysym}
\usepackage{keystroke}
\usepackage{parskip}
\usepackage{booktabs}
\usepackage{tabu}
\usepackage{pifont}
\usepackage{tikz}

\usepackage{graphicx}
\graphicspath{{.}{./images/}}

\setbeamertemplate{navigation symbols}{}

\date{}

\defbeamertemplate*{footline}{my infolines theme}
{
\leavevmode%
\hbox{%
\begin{beamercolorbox}[wd=.1\paperwidth,ht=2.25ex,dp=1ex,center]{author in head/foot}%
\usebeamerfont{author in head/foot}{\underline{\textbf{Author} }}
\end{beamercolorbox}%
\begin{beamercolorbox}[wd=.8\paperwidth,ht=2.25ex,dp=1ex,center]{title in head/foot}%
\usebeamerfont{title in head/foot}Title~---~\insertshorttitle
\end{beamercolorbox}%
\begin{beamercolorbox}[wd=.1\paperwidth,ht=2.25ex,dp=1ex,right]{date in head/foot}%
\usebeamerfont{date in head/foot}\insertshortdate{}\hspace*{2em}
\insertframenumber{} / \inserttotalframenumber\hspace*{2ex}
\end{beamercolorbox}}%
\vskip0pt%
}

\newcommand{\footlineextra}[1]{
    \begin{tikzpicture}[remember picture,overlay]
            \node[yshift=2ex,anchor=south east] at (current page.south east) {\usebeamerfont{author in head/foot}\hspace{2ex}#1};
            \end{tikzpicture}
        }

\newcommand{\footlineleft}[1]{
    \begin{tikzpicture}[remember picture,overlay]
            \node[yshift=2ex,anchor=south west] at (current page.south west) {\usebeamerfont{author in head/foot}\hspace{2ex}#1};
            \end{tikzpicture}
        }

%}}}

\title{\newline Title \newline}
\institute[Institute]{\Large{Institute}\newline \newline \normalsize{\textbf{Some text} normal text\newline \textbf{Some text} normal text\newline \textbf{Some text}}}

\mode<handout>{
  \usepackage{pgfpages}
  \usetheme{default}
  \setbeamercolor{background canvas}{bg=black!5}
  \pgfpagesuselayout{2 on 1}[a4paper,landscape,border shrink=5mm]
\pgfpageslogicalpageoptions{1}{border code=\pgfusepath{stroke}}
\pgfpageslogicalpageoptions{2}{border code=\pgfusepath{stroke}}
\pgfpageslogicalpageoptions{3}{border code=\pgfusepath{stroke}}
\pgfpageslogicalpageoptions{4}{border code=\pgfusepath{stroke}}
}


\begin{document}

\setlength{\parskip}{\bigskipamount}

\begin{frame}[<+->]{Slide 1}

\pause

ONE

\end{frame}

\begin{frame}[<+->]{Slide 2}

\pause

TWO

\end{frame}

\begin{frame}[<+->]{Slide 3}

\pause

THREE

\end{frame}

\begin{frame}[<+->]{Slide 4}

\pause

FOUR

\end{frame}

\end{document}
share|improve this question
1  
Do you get errors with this code? What do you mean you can't print the handouts? Nothing comes out in your pdf? –  hpesoj626 Nov 21 '12 at 8:54
1  
I advise you to update your TeX distribution. Look for the older posts like this collection of older posts on how to install TeXLive 2012 in Ubuntu. –  hpesoj626 Nov 21 '12 at 9:08
    
@hpesoj626 the code compiles properly. But the resultant PDF handout is not proper (2 on 1 OR 4 on 1) –  deshmukh Nov 21 '12 at 10:57
1  
What do regard as wrong with the output? It compiles fine for me, placing two frames on one page above each other with a (thin) border. There is space to the left and right, because of the landscape option you pass to \pgfpagesuselayout. Removing this will make the two frames essentially fill the page. Adding \pgfsetlinewidth{4pt} to your border code before \pgfusepath{stroke} will give you thicker (more visible) border. –  Andrew Swann Dec 21 '12 at 11:55
    
@AndrewSwann, the problem was with the compiler. The same code compiled with xelatex produces incorrect handouts! –  deshmukh Mar 6 '13 at 4:26

3 Answers 3

up vote 0 down vote accepted

OK. After a lot of looking around, I could pinpoint the problem. When you compile the code with xelatex, the handout is not proper. You need to compile it with pdflatex to get the handouts properly.

share|improve this answer

pgfpages seems to be running into issues with Beamer, at least according to

https://bitbucket.org/rivanvx/beamer/issue/183/problem-with-beamer-and-pgfpages-using

(I'm having the same problem). What I do now is ps2dpf the latex/dvips output (without pgfpages) - which will scale up to the right presentation size - and then run a small pdflatex job on it, calling pdfpages

\includepdf[nup=1x2,pages=1-last,delta=1.5 1.5,frame=true]{0.pdf}

(or change nup as desired). Hope that helps.

share|improve this answer
    
Welcome to TeX.sx! You can format your code using the {} button in the edit window or by indenting code rows by four empty spaces –  Peter Jansson Mar 1 '13 at 11:09

I'd look at pdfjam, particularly at pdfnup. Its argument list can be intimidating, but it is extremely flexible. AFAIU, internally it uses LaTeX to do the dirty job of placing multiple pages on one sheet.

share|improve this answer
    
Sure, this seems to be a solution. But I dont know why latex/ xelatex wont be able to produce handouts in the desired configuration –  deshmukh Nov 21 '12 at 10:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.