Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Possible Duplicate:
Reducing the console output of LaTeX

running: C:\Program Files\Text\MiKTeX 2.9\miktex\bin\x64\lualatex.exe -interaction=batchmodesrc-specials main.tex 
lualatex.exe> This is LuaTeX, Version beta-0.70.2-2012060719 (MiKTeX 2.9 64-bit) 
lualatex.exe>  \write18 enabled.
lualatex.exe> Chapter 1.
lualatex.exe> [1{C:/Users/Me/AppData/Local/MiKTeX/2.9/pdftex/config/pdftex.map}] [2]
lualatex.exe> [3] [4] [5] [6] ("C:/Program Files/Text/MiKTeX 2.9/tex/latex/base/t1cmss.fd")
lualatex.exe> [7] [8]
lualatex.exe> Overfull \hbox (12.08553pt too wide) in paragraph at lines 69--271
lualatex.exe>  [] 
lualatex.exe> [9] [10] [11] [12] [13] [14]
lualatex.exe> ("C:/Program Files/Text/MiKTeX 2.9/tex/latex/inconsolata/t1fi4.fd") [15]
lualatex.exe> [16] [17] [18]
lualatex.exe> Chapter 2.
lualatex.exe> 
lualatex.exe> 
lualatex.exe> 
lualatex.exe> 
lualatex.exe> Time: 8s 855ms
lualatex.exe> 

Is the output of my latex after compiling a document with several images included using about 20 packages(tikz, several custom packages, etc...)

I would like to reduce the output even further. Specifically the t1fi4.fd, t1cmss.fd, and pdftex.map line as that is garbage to me. I guess it has to do with fonts and someone left in a message that outputs that junk to the console.

The [] are not so bad and I believe have to do with the included images. With the .fd's gone they will not look so bad and might be useful for a sort of progress report. It would be nice if I could make it skip a few counts though(like every 5 instead of every 1).

The overfull box is sort of annoying but I can fix that easy enough.

Does anyone recognize where the .fd/.map lines are coming from and/or know how to get rid of them?

(I've disabled all outputting messages I could think of but these always show up and break the flow of the program for no good reason)

Thanks

share|improve this question

marked as duplicate by Andrew Swann, Kurt, Thorsten, Guido, Stefan Kottwitz Nov 25 '12 at 12:11

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Why do you need this output to be this streamlined? The [3] printouts count through the pages of the document as they get generate; usually included images show up as referenced files, much like the .fd and .map files do here. –  Mikael Vejdemo-Johansson Nov 25 '12 at 8:15
    
@MikaelVejdemo-Johansson Because I don't wanna see garbage that is irrelevant to the project. those lines I mentioned are absolutely useless. Why do I need to know that some .fd is included? What's the point? To let me know I included the file? Do I need to see it every compilation and have it break the flow of the console output just to let me know each time it was included? (I think I got it the first time) If I need more verbose output I'll enable it by not using batchmode. –  AbstractDissonance Nov 25 '12 at 9:00

1 Answer 1

This is not garbage, but very important information. All text files that are input are recorded, along with the image files that are imported and included in the final PDF.

A .fd file contains the necessary info to use a font; in your case t1cmss.fd contains the information for European Modern Sans (T1 encoding) and t1fi4.fd is for Inconsolata. TeX has no way to distinguish between input files containing your document proper or auxiliary files such as .fd: it simply logs every input file. In particular it logs the pdftex.map file and it's very important to know which one has been loaded in case of problems with the pairing between .tfm files and .pfb/.pfa files.

The [] annotation that you find is simply a very scanty representation of the reported overfull box; if you had set in the preamble

\showboxdepth=10 \showboxbreadth=100

you'd have seen more than [] (LaTeX sets the two parameters to zero).

You may want to examine the texloganalyser script that's included in TeX Live (and possibly in MiKTeX). But removing this from the terminal output requires changing the sources of TeX or LuaTeX.

share|improve this answer
    
texloganalyser is not running with pure MiKTeX. You need a perl interpreter like cygwin to run it as I know. –  Kurt Nov 25 '12 at 12:12
    
Huh? Why has this answer been downvoted so often? –  cgnieder Nov 25 '12 at 16:16
    
@cgnieder Of course people is free to downvote my answer, if they think it deserves it; what's curious here is +6/-3, with no comment whatsoever (I believe that the comment by Kurt doesn't warrant a downvote). –  egreg Nov 25 '12 at 17:40
    
@Kurt: Cygwin is not a perl interpreter. I could get texloganalyser working with exactly the same approach like for fancytooltips in tex.stackexchange.com/a/83039. –  Speravir Nov 26 '12 at 2:53
    
@egreg: my comment means no downvote, it should only add that texloganalyser is not so easy running with MiKTeX. BTW: sometimes I use it ;-) –  Kurt Nov 26 '12 at 3:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.