TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use TeX Live 2012 on an updated Ubuntu 12.10 machine with Latexila. I intended using Adobe's open source font Source Sans Pro in my latest paper.

I followed the instruction on the LaTeX Font Catalogue page, inserted


but Latexila only spits out the following error:

File 'sourcesanspro.sty' not found.

I already installed all LaTeX extra packages, I could find with apt-get.

Any ideas?

share|improve this question
how did you installed sourcesanspro? I suppose that Ububtu dosn't have that package in the current version. If so, install it by yourself – Herbert Nov 25 '12 at 16:27
Ay, I thought it would come with apt-get install texlive-fonts-extra as this package got displayed when I searched for apt-cache search Source Sans. Probably though, this did not suffice! – mcbetz Nov 25 '12 at 16:35
no, that is the major difference between Ubuntu-TeXLive and TUG-Texlive from tug.org/texlive. Ubuntu updates it only one time per year and TUG daily! – Herbert Nov 25 '12 at 16:44
get ftp.fu-berlin.de/tex/CTAN/fonts/sourcesanspro.zip unzip it and put the the files in the same directories of ~/texmf/.... Then run sudo updmap-sys --enable Map=SourceSansPro.map – Herbert Nov 25 '12 at 16:53
You can follow the quick install guide to install vanilla TeX Live. Also read the additional information for Ubuntu. If you have questions about the sourcesanspro package you can ask me in the chat room. Manual install is easiest with the TDS zip. If you're brave try the development version. – Silke Nov 26 '12 at 21:08
up vote 10 down vote accepted

You should get an updated version of TexLive - which you obviously did not do before. The latest version includes Source Sans Pro.

It is however not in the official repository for 12.04 and 12.10, so you have to add an unofficial one:

$ sudo add-apt-repository ppa:texlive-backports/ppa

After that, you can install TexLive with apt, not forgetting to get the font package:

$ sudo apt-get install texlive
$ sudo apt-get install texlive-fonts-recommended texlive-fonts-extra

You can now use Source Sans Pro:

% LaTeX

Or for XeLaTeX:

% !TEX TS-program = XeLaTeX
\setsansfont{Source Sans Pro}
share|improve this answer
As the maintainer of the sourcesanspro package I'd like to point out that \usepackage[default]{sourcesanspro} uses the OpenType fonts if you use XeLaTeX or LuaLaTeX. – Silke Jan 23 '13 at 16:56
Thanks for the comment. Does it mean, the special command for XeLaTeX is not needed? I may delete it from my answer - or you can do so. – mcbetz Jan 23 '13 at 21:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.