TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'd like to use the external library with TikZ. There I want to use the "up to date check". But when activating the key in this minimal example I got the error:

! Package pgfkeys Error: I do not know the key '/tikz/external/up to date check' and I am going to ignore it. Perhaps you misspelled it.

This is the minimal example I used:

\tikzexternalize[  prefix=figures/
    %, up to date check=md5
    %, force remake


    \node[draw, circle, minimum width=2cm, red] {};
    \draw (0, 0) -- (1, 1);


I updated my MiKTeX distribution, but nothing changes.

share|improve this question

closed as too localized by lockstep, Martin Schröder, Stefan Kottwitz Nov 26 '12 at 12:59

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

I can't find anything in the documentation about that key, where did you read about it exactly? – T. Verron Nov 26 '12 at 10:47
I read it in the manual pgfmanualCVS2012-11-04.pdf (texample.net/media/pgf/builds/pgfmanualCVS2012-11-04.pdf) on page 405. – Dirk Nov 26 '12 at 11:01
Will replacing \tikzsetexternalprefix{figures/, up to date check=md5, force remake} instead of \tikzexternalize[ prefix=figures/,up to date check=md5, force remake] work for you? – hpesoj626 Nov 26 '12 at 11:13
That is the manual of the CVS version, which is not same as the one found in the MikTeX repos. You'll have to download the CVS build from Texample, and install it manually. – Torbjørn T. Nov 26 '12 at 11:21
I get the same error on a current TeXlive (full update literally minutes before I post this). The pgfmanual I see the option described in is from May 2012, so I guess it should work by now. Not sure "too localized" is the correct answer here. – Raphael Nov 26 '12 at 21:09

Browse other questions tagged or ask your own question.