Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

How can I add a word to the dictionary of TexMaker? I cannot see any options for this in the software.

share|improve this question
1  
This question about adding external dictionaries to Texmaker may be helpful. –  Andrew Uzzell Nov 27 '12 at 11:37
add comment

3 Answers

up vote 8 down vote accepted

If adding is what you just need then this answer might work for you. If you want to install a new dictionary, follow the link in the comment. With your terminal, cd to the directory of your TeXMaker dictionary. If you don't know where, in TeXMaker click

Options > Configure TeXMaker > Editor

You can see the directory of the dictionary in the option Spelling dictionary. In Ubuntu, once you are in the directory, type

sudo gedit en_GB.dic

and put the word you want to add in there.

In Windows, just go to the directory and double click on the file or open with Notepad. Then write the word you want to add.

You might also want to save the customized file in another folder and have your Spelling dictionary option point to the custom file.

share|improve this answer
    
thanks, that is a very long way round to add words to a dictionary. I can't believe they haven't got this functionality in built. Thanks anyway, that will have to do for now I guess. –  fpghost Nov 27 '12 at 15:26
    
Just FYI, the fork TeXStudio has a tool called Thesaurus that you can use to add words to the dictionary. I haven't been using it as often as before though. –  hpesoj626 Nov 27 '12 at 16:55
2  
Just to add a useful bit of info for Windows users: the dictionary files are in the base folder of the TexMaker installation and need to be opened with Administrator privileges. –  Aleksandar Savkov Jun 13 '13 at 11:04
add comment

In the newer versions they have also added a "Spell check" feature (Control + Shift + F7) which allows you to add new words.

The custom words are stored in $HOME/.config/xm1/texmaker.ini.

share|improve this answer
1  
Welcome to TeX.sx! –  Peter Jansson Apr 25 '13 at 19:31
    
Great key, since the feature seems not to be accessible from the menu –  fstevens Mar 12 at 8:53
add comment

In version 4.1.1, you can right click a word underlined in red and then click "Check Spelling Selection". That will open a dialog box where you need to click "Always Ignore".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.