Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Have read (carefully, I hope) the earlier question Font installation in TeXShop on a Mac looked to be exactly what I needed. Also looked at http://www.tug.org/fonts/fontinstall.html#fndb

Am trying to install Arial from CTAN.

However, the sudo commands getnonfreefonts, texhash and updmap did not seem to be available on my system. So I have downloaded and installed MacTeX 2012 (previously had 2010), which enabled texhash and updmap, but not getnonfreefonts, and tried again.

The unzipped files went into /usr/local/texlive/2012/../texmf-local/arial which I think is right.

sudo texhash made all the right noises, as in the answer to the earlier question referred to above.

sudo updmap-sys --enable Map=ua1.map produced a limited response. I had made earlier attempts, sometimes with the wrong map name. The font is not 'working'. testfont confirms this, saying that ua1b8a (one of the .tfm files) cannot be found.

I have clearly 'screwed up' my system somewhere along the line, unless I have misunderstood something. What do I do now? Remove all traces of TeX... from my computer and start again? Or...

Sorry to be so dumb.

share|improve this question
    
I have the similar problem and tried to install the getnonfreefonts. But my Mac doesn't know the command texlua. Really I tried it the whole day and stuck for this shit. Can you please help me? –  Moritz Pfeiffer Feb 19 '13 at 21:38

2 Answers 2

Don't be dramatic! ;-) If the distribution didn't install getnonfreefonts you can install it yourself and it will do his magic in a few steps.

Download getnonfreefonts

Get the program at http://www.tug.org/fonts/getnonfreefonts/ and follow the very simple instructions on the very page I pointed. Assuming you installed the Tex Live distro system-wide, you may want to modify the commands in

sudo env PATH=$PATH texlua install-getnonfreefonts

assuming also that your PATH points to the Tex Live binaries (which should be).

Install arial-urw

You should be fine with

sudo getnonfreefonts arial-urw

and voila! Font installed. :-)

share|improve this answer
    
Many thanks. I was dumb, but now all sorted. LaTeX fonts unlocked! –  Graham Howlett Dec 4 '12 at 0:20
    
Don't forget to mark the answer as accepted. ;-) –  Marcello Massaro Dec 5 '12 at 8:16

Install the TeX Live Utility GUI, which lets you easily install fonts with a single click, etc

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.