Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I want to use the [bp] font size for the whole document in Lyx 2.0.4 for compilation with XeLatex. My LaTex preamble looks like this: \usepackage{fontspec} \usepackage{xunicode} \usepackage{xltxtra} \date{}. If I specify \documentclass{article}[12bp] I get these errors: LaTex Error: Two \documentclass or \documentstyle commands and LaTex Error: Missing \begin{document}.

share|improve this question
    
I would just use 12pt (\documentclass[12pt]{article}), that's quite close, but well supported. –  Heiko Oberdiek Nov 27 '12 at 22:20
    
If I do that I get LaTex Error: Two \documentclass or \documentstyle commands. But I want to use [bp], as I said, not [pt]. Is that even possible (avoiding the error, of course)? –  riderplus Nov 27 '12 at 22:23
    
The error: consult the documentation of LyX. Using bp instead of pt: You would have to redefine lots of macros (all font size commands, ...), because pt is the standard unit in TeX, not bp. –  Heiko Oberdiek Nov 27 '12 at 22:25
    
I couldn't find anything related to that errror. So there's no easy way of using bp instead of pt. That's a pity, MSWord uses bp and it would make it difficult for me to write my thesis, I would end up filling less space. –  riderplus Nov 27 '12 at 22:31
    
@riderplus The reduction in font size is marginal. Hopefully, your are evaluated by content, and not turned down because the thesis is a line too short. –  Sveinung Nov 27 '12 at 22:48
show 3 more comments

1 Answer

The error is nothing to do with the units, just a syntax error in your command which should be

\documentclass[12pt]{article}

you have the [ after the class name so it is not taken as an optional argument but just as normal text, so you get an error that you can not have text before \begin{document} The difference in size between a 12pt font and a 12bp font is no difference at all, you get more difference between two nominally 12pt size fonts of different design, The label attached to a font size is only indirectly related to any actual measurement. 12bp is 12.045pt the difference in height of two nominally 12pt fonts can easily be more than that.

share|improve this answer
    
Thank you, but that doesn't answer my question. How can I work with [bp] instead of [pt]? The MSWord font is clearly larger than TeX's [pt]. –  riderplus Nov 28 '12 at 19:34
    
By the way, the error still shows up even if I change it as you said. It may be a bug in LyX 2.0.4. About the difference between two nominally 12pt size fonts of different design you are right, but that doesn't answer my question. –  riderplus Nov 28 '12 at 19:40
    
I've tried putting in the preamble of a LyX 1.6.5 \documentclass[12pt]{article} and it gives the same error. –  riderplus Nov 28 '12 at 19:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.