Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

The pdflatex.exe process hungs. I have two TeX files, FIRST imports SECOND (by using combine class). SECOND file has \includegraphics{DDS_images_eps/SIN_0.eps}, and compiles fine. But FIRST hungs. In FIRST file I commented all unnecessary fields. Ending of FIRST file Log is

Package epstopdf Info: Source file: <DDS_images_eps/SIN_0.eps>
(epstopdf)                    date: 2011-04-24 06:05:44
(epstopdf)                    size: 130169 bytes
(epstopdf)             Output file: <DDS_images_eps/SIN_0-eps-converted-to.pdf>    
(epstopdf)                    date: 2012-10-31 15:46:56
(epstopdf)                    size: 8670 bytes
(epstopdf)             Command: <epstopdf --outfile=DDS_images_eps/SIN_0-eps-converted-to.pdf DDS_images_eps/SIN_0.eps>
(epstopdf)             \includegraphics on input line 479.
Package epstopdf Info: Output file is already uptodate.

<DDS_images_eps/SIN_0-eps-converted-to.pdf, id=94, 676.5275pt x 126.4725pt>
File: DDS_images_eps/SIN_0-eps-converted-to.pdf Graphic file (type pdf)    
<use DDS_images_eps/SIN_0-eps-converted-to.pdf>
Package pdftex.def Info: DDS_images_eps/SIN_0-eps-converted-to.pdf used on input line 479.
(pdftex.def)             Requested size: 155.99762pt x 29.16139pt.
Package epstopdf Info: Source file: <DDS_images_e

What's the problem?

UPDATE:MWE

SECOND file

\documentclass[12pt,notitlepage]{article}
%\usepackage{graphicx}
%\usepackage{subfig}
\begin{document}
\begin{figure}[!h]
     \includegraphics[width=0.4\textwidth]{SIN_1800.pdf}
     \caption{Ground state}
\end{figure}
\end{document}

FIRST file

\documentclass[report,12pt,a4paper,twoside]{combine} 
\usepackage{graphicx}
\usepackage{subfig}
\begin{document}
\begin{papers}
    \import{MWE_child}
\end{papers}
\end{document}

MWE work if I disable subfig package or \caption{..}. But I can't disable it. Rest of the file can use it.

Nevertheless, when I compile SECOND file(with uncomment packages) it work fine.

share|improve this question
    
Please add a minimal working example (MWE) that illustrates your problem. It is considered a lot better to put in some code that will compile, as it makes it a lot easier for us to copy it into our text editor and work with it, and see exactly what it is you are trying to do. –  Stephan Lehmke Nov 28 '12 at 14:46
2  
The protocol only shows a successful graphics inclusion. Try to make a MWE or at least try to identify the problematic source code lines, e.g. by moving \end{document} around, or adding \show\x or \typeout{...} as debugging helpers. –  Heiko Oberdiek Nov 28 '12 at 16:01
    
I tested a little, when I add \caption{sometext} between \begin{figure}[!h] and \end{figure} it doesn't work, but if I remove \caption all work fine. What is wrong? –  Jupiter Nov 28 '12 at 16:39
    
I can't understand what is the problem, so I just replaced \usepackage{subfig} commands by \usepackage{caption}, \usepackage{subcaption}commands. It works. –  Jupiter Nov 29 '12 at 17:48
add comment

1 Answer

It's not possible for pdflatex to use eps files. You can convert them using the ps2pdf command from the ghostscript package and then include the PDFs.

share|improve this answer
2  
I use epstopdf package. So if pdf file doesn't exist, epstopdf build it(i compile SECOND file), but in case with FIRST file latex hungs. –  Jupiter Nov 28 '12 at 15:52
1  
the epstopdf package requires the shell-escape feature; have you enabled that? –  wasteofspace Nov 28 '12 at 15:53
    
Hmm, I disabled epstopdf and included pdf files(in SECOND file). But FIRST file doesn't compile. –  Jupiter Nov 28 '12 at 16:26
    
@wasteofspace epstopdf doesn't need --shell-escape, for TeX Live 2011 or later and, I believe, with MiKTeX 2.9 –  egreg Nov 28 '12 at 18:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.