Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

When using the esvect package in a transparency context, one can see that the arrow is built by superposing two "blocks": a line and an arrowhead. But as the line overrides the arrow head, the center of the arrow looks less transparent.

Is there a way to change this modifying esvect code?

Transparency issue

\documentclass{standalone}

\usepackage{tikz}
\usepackage{esvect}

\begin{document}

\begin{tikzpicture}
  \node[semitransparent] {$\vv{v}$};
\end{tikzpicture}

\end{document}
share|improve this question
1  
If I open with evince or okular I can see what you mean, but with adobe reader all is perfectly rendered. –  Claudio Fiandrino Nov 29 '12 at 14:41
add comment

1 Answer 1

up vote 2 down vote accepted

This is something of a work-around for your specific example (I don't know if that was just the simplest way to get the arrow semi-transparent or if that is your actual use-case). The work-around is to use transparency group.

\documentclass{standalone}

\usepackage{tikz}
\usepackage{esvect}

\begin{document}


\begin{tikzpicture}
\begin{scope}[transparency group,semitransparent]
  \node {$\vv{v}$};
\end{scope}
\end{tikzpicture}

\end{document}

transparent arrow

If you look closely, you can still see the effect in that the line is slightly thicker where the two pieces overlap, but it is much less evident that the transparency difference.

share|improve this answer
    
I don't know if I'll be able to use this workaround in every situation if I need to add a scope. I need to look at the doc to see what it is said about transparency group (a key I did not remember BTW :)) –  cjorssen Nov 29 '12 at 15:02
    
BTW what setting did you use to get the big picture unpixellized? –  cjorssen Nov 29 '12 at 15:03
    
I suppose one could define code to automatically put every node in a scope - there's code to do it with layers lying around on this site. For the picture, I took a screenshot - I keep trying with the settings for convert but I can never remember the right invocation. –  Loop Space Nov 29 '12 at 15:18
    
Ok. It works for me. Thanks. And the screenshot is a good tip :) –  cjorssen Nov 29 '12 at 21:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.