Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have a problem with manually sorting the entries for my nomenclature by the prefixes, and I cannot get it to work. Here is my code; they are supposed to be sorted by the numbers in the prefixes, i.e. in the order they are written here:

\documentclass[12pt]{scrartcl}
\usepackage[english]{babel}
\usepackage{amsmath}
\usepackage{amssymb}
\usepackage{pslatex}
\usepackage[intoc]{nomencl}

\makenomenclature

\begin{document}

% cd C:\THE FOLDER\makeindex reportneu.nlo -s nomencl.ist -o reportneu.nls

\printnomenclature[2cm]
\nomenclature[1]{$A,B$}{Countries $A,B$.}
\nomenclature[2]{$C$}{Fixed cost}
\nomenclature[3]{$\underline{C}$}{The lower bound}%
\nomenclature[6]{$E$}{The equilibrium tax rates for the symmetric case.}
\nomenclature[8]{$n$}{The size factor}
\nomenclature[9]{$\overline{n}$}{The value}
\nomenclature[10]{$p_A,p_B$}{The price}
\nomenclature[15]{$\Pi_{kl}$}{The total operating profits }
\nomenclature[20]{$\emptyset$}{The non-entry option}

\end{document}

where makeindex reportneu.nlo -s nomencl.ist -o reportneu.nls is what I enter in the command line (filename is reportneu.tex)

Here is what I tried: - rename the file, and change the code "makeindex reportneu.nlo -s nomencl.ist -o reportneu.nls" accordingly, to run it freshly - result: the nomenclature stayed in the same order (the default order, apparently; it goes: $A,B$ < $p_A,p_B$ < $\Pi_{kl}$ < ... < $\overline{n}$)

  • delete all latex files except for the .tex-file in the directory - no effect

  • delete one row in the above nomenclature and run the makeindex-command again: Effect: the nomenclature did not include that entry anymore, but the remaining order stayed the same.

  • try both \usepackage[intoc,noprefix]{nomencl} and \usepackage[intoc]{nomencl} - no effect

there is also no error when I execute the makeindex-command, look:

C:\Arbeit\Unisachen\Fall 2012\Managerial Economics>makeindex reportneu.nlo -
s nomencl.ist -o reportneu.nls
This is makeindex, version 2.15 [MiKTeX 2.9 64-bit] (kpathsea + Thai support).
Scanning style file C:/Program Files/MiKTeX 2.9/makeindex/nomencl/nomencl.ist...
.......done (10 attributes redefined, 3 ignored).
Scanning input file reportneu.nlo....done (20 entries accepted, 0 rejected).
Sorting entries....done (104 comparisons).
Generating output file reportneu.nls....done (46 lines written, 0 warnings).
Output written in reportneu.nls.
Transcript written in reportneu.ilg.

(there are 20 entries in total, I left most out here). Any help is looked forward to and greatly appreciated!

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

The sorting order is correct, because it is performed lexicographically on the prefixes:

1 10 15 2 20 3 6 8 9

Say

\nomenclature[01]{$A,B$}{Countries $A,B$.}
\nomenclature[02]{$C$}{Fixed cost}
\nomenclature[03]{$\underline{C}$}{The lower bound}%
\nomenclature[06]{$E$}{The equilibrium tax rates for the symmetric case.}
\nomenclature[08]{$n$}{The size factor}
\nomenclature[09]{$\overline{n}$}{The value}
\nomenclature[10]{$p_A,p_B$}{The price}
\nomenclature[15]{$\Pi_{kl}$}{The total operating profits }
\nomenclature[20]{$\emptyset$}{The non-entry option}

(0 comes before the other digits)

Your MWE is not correct: you need to typeset something in order that the .nlo file is output. Just add a word after \begin{document}. Here's what I get:

enter image description here

share|improve this answer
    
...perfect. thanks! –  Marie. P. Nov 30 '12 at 0:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.