Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using Mikitex + Texmaker for writing a IEEETrans paper and i am a novice in all this. I have a test file which I am using for understanding how to insert bibliography. Thus, I have two files namely test_bb.tex and bb.bib. I have made all the settings as mentioned in this link on the same forum

Configuring TexMaker and BibTex

Here is the code snippet of settings after using wizard

pdflatex -synctex=1 -interaction=nonstopmode %.tex|bibtex %|pdflatex -synctex=1 - interaction=nonstopmode %.tex|pdflatex -synctex=1 -interaction=nonstopmode %.tex

so when I compile the test_bb file manually one by one (PDFLaTeX -> BibTex -> PDFLaTeX -> PDFLaTeX) or by quick build (as set in wizard of Texmaker) I get following stupid error while doing BibTex. Both bib and tex files are at the same location. I can't see the references and citation at all. even I have tried it after deleting log and aux files in build folder but no success.

This is the error

Process started

I couldn't open file name `test_bb.aux'

Process exited normally

The code snippet is as under for both files

tex file

\documentclass[conference]{IEEEtran}
\usepackage{cite}
\begin{document}
\title{Sample IEEE paper style using Latex}
\author{\IEEEauthorblockN{Author first, Author Second, and Author Third}
\IEEEauthorblockA{Department \\
 University\\
 City - State - Zip \\
 Email: xxxx@xx.com}
 }
 \maketitle
 \begin{abstract}
   This is an abstract.
 \end{abstract}
 \section{Introduction}
 \label{sec:intro} 
  Here is a modified text sample for intro section using latex. This is a citation   \cite{author1} This is how you refer a section in another section Section~\ref{sec:meth}     ..... 
  \section{Methodologies} 
  \label{sec:meth} 
  This is the other section that you can use.
  \bibliographystyle{IEEEtran}
  \bibliography{bb}
  \end{document}

and bib file is as under:

@ARTICLE{author1,
 author = {John Frederik Camelot Smith and Jason Bourne},
 title = {{The Pain of Having a Foolish Name}},
 journal = {Journal of Modern Fiction},
 year = {2009},
 volume = {52},
 pages = {114},
 number = {1},
 issn = {0010-4620},
 publisher = {Grendel Publishing}
}

Please help...

share|improve this question
    
welcome to tex.sx, does the first pdflatex run run to the end and leave a test_bb.aux file in the current directory? If there are other tex errors stopping the first run writing the aux file, then later bibtex or pdflatex runs are going to do the wrong thing. Generally it's easier to help if you can make a complete small tex document that shows the problem rather than just a fragment that we can't run locally. –  David Carlisle Dec 1 '12 at 13:02
    
@David The aux file is in a default build folder. After first run I only get two warnings i.e 1. citation author1 on page 1 is undefined. 2. There were undefined references. (The above post is edited and whole code is added). I am pretty new in Latex and only knows this I don't know how to show a problem document. –  Skipper07 Dec 1 '12 at 13:16
    
@Skipper07 I would recommend starting with TeXNicCenter if you're new to LaTeX. It eases the build process a lot. Simply install, run, tell it where to find MikTex, create a new document, set up a project (using Project->Create with Active Document as Main File, check BibTeX) and build project 3 times :) –  recluze Dec 1 '12 at 13:26
    
I have noticed the same thing. Texmaker does not seem to be very robust with its source file handling. It simply does not play well with Bibtex. I just spent about an hour trying to get it to work, to no avail. Finally, I fired up TexWorks (came with the MikTex Package) and ran bibtex from there. It worked fine, no problem. Texmaker refuses to work right. Possible issue: do you use the 'Put output files in build directory' option? That may break things. –  Chris Feb 3 '13 at 16:43

4 Answers 4

There is nothing wrong with your input: pdflatex, bibtex, pdflatex, pdflatex, produces the result below.

I would guess that pdflatex (or your editor) have been configured to write the .aux file to somewhere other than the directory containing the tex file, and then bibtex can not find it.

So the solution would be not to do that but I haven't used that editor so I can't help with the settings. Making this an answer rather than a comment for ease of formatting.

enter image description here

share|improve this answer
2  
Your guess is right. I have just changed the settings that the .aux file shouldn't be written in a build folder and everything works fine...Thanks a lot...I was trying to solve it for last 2 days and you made my day. –  Skipper07 Dec 1 '12 at 13:32

If you are using a ´build´ subfolder for your output files, the generated aux file will be placed there. A simple way to solve this problem is to edit the configuration of Texmaker.

bibtex build\%

This should do the trick. Try to run Bibtex, this should work fine. If you want to use your own defined sequence of executing (PDFLatex BibTex PDFLatex PDFLatex) you need to update that one as well, since this is still stuck with the old bibtex command (without the build\ addition). See the screenshot below for the implementation in the texmaker configuration screen:

enter image description here

share|improve this answer
    
Welcome to TeX.sx! –  Peter Jansson Apr 2 '13 at 12:12
    
On windows I had to use "bibtex build/%" but this worked for me –  Brian Paden Oct 5 '13 at 6:45

Change bib(la)tex command line property to:

bibtex build/% -include-directory=build

This enables BibTeX to find not only main file but also indirectly referenced .aux files.

share|improve this answer

With TeXworks, give the same name to the LaTeX file and the BibTeX file. For example:

myfile.tex

myfile.bib

compiling myfile.tex yields myfile.aux.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.