Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I would like to re-align my title, authors and abstract to the left of the document. The example in this question is basically the output I want, but I do not want to use the memoir environment.

MWE:

\documentclass[10pt]{article}
\usepackage[]{lipsum}

\usepackage{todonotes} % add [disable] to switch off

\title{Neque porro quisquam est qui dolorem ipsum quia dolor sit amet, consectetur, adipisci velit}
\date{}
\author{%
    Author One$^{1}$, Author2$^{2}$\\
    $^{1}$Institution 1, I 1 City, I 1 Country\\
    $^{2}$Institution 1, I 1 City, I 1 Country\\
    \underline{$^{1}$mail@domain.com}\\
    \underline{$^{2}$mail2@domain.com }
}

\pagestyle{empty} % disables page numbers
\thispagestyle{empty} % single page disable page number

\begin{document}
\maketitle
\textbf{Abstract:} \lipsum[3]
\end{document}

gives me: This output

but I would prefer it to look more like (in terms of alignment and font size - bonus): ideal

I've tried various alignment options, but can't seem to get inside the \maketitle. Any suggestions appreciated, as I haven't done much with regards to forcing overrides on defaults. Would I use renewcommand?

I've also tried

\begingroup
\let\center\flushleft
\let\endcenter\endflushleft
\maketitle
\endgroup

but the author section is then odd looking:

flushleft

share|improve this question

1 Answer 1

up vote 3 down vote accepted

The package titling provides esseentially the functionality found in the memoir class for titles. However in your case, it is simpler to redefine the \maketitle command directly.

\documentclass[10pt]{article}

\usepackage{lipsum}

\makeatletter
\renewcommand{\maketitle}{\bgroup\setlength{\parindent}{0pt}
\begin{flushleft}
  \textbf{\@title}

  \@author
\end{flushleft}\egroup
}
\makeatother

\title{Neque porro quisquam est qui dolorem ipsum quia dolor sit amet, consectetur, adipisci velit}
\date{}
\author{%
Author One$^{1}$, Author2$^{2}$\\
$^{1}$Institution 1, I 1 City, I 1 Country\\
    $^{2}$Institution 1, I 1 City, I 1 Country\\
    \underline{$^{1}$mail@domain.com}\\
    \underline{$^{2}$mail2@domain.com }
}

\pagestyle{empty} % disables page numbers

\begin{document}
\maketitle
\thispagestyle{empty} % single page disable page number

\noindent
\textbf{Abstract:} \lipsum[1]
\end{document} 

Sample output

The title and author information is to be found in the commands \@title and \@author. As these include the character @ in their names the refinition of \maketitle has to be included in at \makeatletter / \makeatother group.

I have also moved your \thispagestyle command to after the \begin{document}, so that it takes affect.

You didn't specify what spacing you wanted before the title. You can add vertical space after the \bgroup in the new \maketitle using say \vspace*{2cm}.

share|improve this answer
    
So, just to be sure I understand correctly. You are overriding the maketitle command, inside of that you create a new group, you flushleft this group, and use the @variables to use the already defined title and author. I'm a bit confused as to what makeatletter and makeatother is responsible for. Noindent removes the indentation. –  Forkrul Assail Dec 3 '12 at 16:24
2  
Your understanding is correct. The \makeatletter changes the catcode of @ from a non-letter class other to the letter category, so it is allowed in command names. LaTeX uses this mechanism to hide internal commands from users. –  Andrew Swann Dec 3 '12 at 16:38
    
Thank you so much for the extensive, timely and helpful answer. –  Forkrul Assail Dec 3 '12 at 16:43
    
When trying to add \newline between authors this errors pop up There's no line here to end \maketitle –  Misaki Jul 22 at 13:07
    
@Misaki Works OK for me, though it would be more consistent to use `\`. If you still have a problem, please post a separate question including the code you have tried. –  Andrew Swann Aug 11 at 12:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.