Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm using the krantz.cls to write a book, and I ran into an error with the hyperref package. Here is a minimal example (test.tex):

\documentclass{krantz}
\usepackage{hyperref}
\begin{document}
\chapter{Introduction}
\end{document}

When I compile it with pdflatex test.tex, I get this error:

Runaway argument?
{Introduction}]{[}{Introduction}]{Introduction} \end {document} 
! File ended while scanning use of \Hy@org@chapter.
<inserted text> 
                \par 
<*> test.tex

Without hyperref, it compiles fine. I appreciate if anyone can tell me why this happens and how to fix it.

$ pdflatex --version
pdfTeX 3.1415926-2.4-1.40.13 (TeX Live 2012/Debian)
kpathsea version 6.1.0
Copyright 2012 Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
There is NO warranty.  Redistribution of this software is
covered by the terms of both the pdfTeX copyright and
the Lesser GNU General Public License.
For more information about these matters, see the file
named COPYING and the pdfTeX source.
Primary author of pdfTeX: Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
Compiled with libpng 1.2.49; using libpng 1.2.49
Compiled with zlib 1.2.7; using zlib 1.2.7
Compiled with poppler version 0.20.4

$ head `kpsewhich hyperref.sty` -n 34 | tail -n 4
\NeedsTeXFormat{LaTeX2e}[1995/12/01]
\ProvidesPackage{hyperref}
  [2012/05/13 v6.82q %
  Hypertext links for LaTeX]

Update

I contacted the author of this package and the problem was solved. See the corrected krantz.cls.

Does not work with recent versions of HyperRef

I figured out that the recent versions of the krantz class do not work with the latest version of hyperref. I systematically tried versions from:

ftp://download.gnu.org.ua/pub/release/hyperref/

The crash occurs at starting at version

File: hyperref-6.83b.tds.zip 3925 KB 18/08/2012 12:00:00 AM

and higher (crashes with 6.83c, 6.83f, 6.83k, 6.83m) and will compile with the earlier version

File: hyperref-6.83a.tds.zip 3915 KB 13/08/2012 12:00:00 AM

The older version 6.83a has lines like:

\hyper@linkstart{link}{#4}{#2}\hyper@linkend

and has been replaced in the newer version 6.83b with

\hyper@linkstart{link}{\Hy@tocdestname}{#2}\hyper@linkend

The error that is generated when compiling with 6.83b is

! Undefined control sequence.
<argument> \Hy@tocdestname

l.6 \tableofcontents

?

My guess is that is the region causing the errors.

So the work around is to use hyperref version 6.83a.

share|improve this question
    
Seems to be an error in the class; contact the author. –  Martin Schröder Dec 8 '12 at 13:37
    
Despite the class' claim - this is not a standard LaTeX class. In particular its internal command \@chapter used for chapters has a non-standard argument format, which hyperref therefore does not recognise. –  Andrew Swann Dec 8 '12 at 18:08
    
@AndrewSwann Thanks a lot! That \@chapter is exactly what I want to know; at least I know the direction to fix it now. –  Yihui Dec 8 '12 at 18:11
add comment

closed as too localized by Martin Schröder, Kurt, Stephen, Andrew Swann, Stefan Kottwitz Dec 8 '12 at 19:22

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.