Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Image is here

The chapter number is black, but it should be light gray. I have not modified anything in the layout files and have downloaded fresh one. Has anyone got a clue where I can change to adjust the color back to light gray?

share|improve this question
    
Can you provide a minimal working example (MWE)? –  hpesoj626 Dec 10 '12 at 0:54
    
Yes, would have to come back to this tomorrow. However, if anyone has experienced this before, it would save me some trouble. –  Stian Dec 10 '12 at 1:17
5  
Well, I don't know if somebody has experienced this before, but I think you can save them the trouble of guessing what is happening in your code. But, well, there is always tomorrow. :) BTW, Welcome to TeX.sx! –  hpesoj626 Dec 10 '12 at 1:23
3  
I'm sorry, the object of this site isn't "to save me some trouble", but "to allow me to be part of a community where we can all help each other to solve our common problems and improve our knowledge". –  Brent.Longborough Dec 10 '12 at 9:20
    
The problem was with XeTex, it seems that using something else fixes the problem! If anyone has a suggestion for the best graphics driver, it would be great. –  Stian Dec 10 '12 at 16:35
add comment

1 Answer

This is the code that classicthesis uses to set the chapternumber:

\titleformat{\chapter}[display]%
    {\relax}{\mbox{}\oldmarginpar{\vspace*{-3\baselineskip}\color{halfgray}\chapterNumber\thechapter}}{0pt}%
    {\raggedright\spacedallcaps}[\normalsize\vspace*{.8\baselineskip}\titlerule]% 

There are no options in classicthesis to alter the colour of the chapter number, so unless you changed it in those lines, one of your packages and/or changes are responsible for the black number.

You could add the following to your preamble, which would "reset" the original code at the beginning of the document. So if you (or one of your packages) are responsible for the black colour, this should reset the changes.

\AtBeginDocument{%
    \titleformat{\chapter}[display]%
        {\relax}{\mbox{}\oldmarginpar{\vspace*{-3\baselineskip}\color{halfgray}\chapterNumber\thechapter}}{0pt}%
        {\raggedright\spacedallcaps}[\normalsize\vspace*{.8\baselineskip}\titlerule]%
}

Note that this is not a fix. A fix would be to construct an MWE in order to find out how the error occured in the first place.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.