Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I writing a document in LyX (2.0.5) with references. For displaying references I use biblatex. (http://wiki.lyx.org/BibTeX/Biblatex). My latex environment is MiKTeX 2.9

Since I switched my Desktop, converting following tex files to pdf doesn't work anymore. Converting the Lyx file (which following tex file is exported from) doesn't work either.

Here is my tex file:

%% LyX 2.0.5 created this file.  For more info, see http://www.lyx.org/.
%% Do not edit unless you really know what you are doing.
\documentclass[11pt,oneside,chapterprefix=on]{scrbook}
\usepackage{helvet}
\renewcommand{\familydefault}{\sfdefault}
\usepackage[T1]{fontenc}
\usepackage[cp1252]{inputenc}
\usepackage[a4paper]{geometry}\geometry{verbose,tmargin=3cm,bmargin=3cm,lmargin=2cm,rmargin=2cm,headheight=1cm,headsep=1cm,footskip=1.2cm}
\setcounter{secnumdepth}{3}
\setcounter{tocdepth}{3}
\usepackage{amsmath}
\usepackage{fixltx2e}
\usepackage{setspace}
\onehalfspacing
\usepackage[unicode=true,pdfusetitle,
 bookmarks=true,bookmarksnumbered=false,bookmarksopen=false,
 breaklinks=true,pdfborder={0 0 1},backref=false,colorlinks=false]
 {hyperref}

\makeatletter
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% Textclass specific LaTeX commands.
\numberwithin{figure}{section}
\numberwithin{table}{section}
\numberwithin{equation}{section}

\@ifundefined{date}{}{\date{}}
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% User specified LaTeX commands.
\usepackage[style=alphabetic,natbib=true,backend=biber]{biblatex}
\bibliography{list-4.bib}
\typeout{File: \jobname.bcf}

\makeatother

\begin{document}

\chapter{Introduction}    
Test (\citealp[see][p.1]{Alter1980})

\chapter{Literature}
\printbibliography
\end{document}

My bib file look like this:

@book{Alter1980,
author = {Alter, Steven L.},
 year = {op. 1980},
 title = {{D}ecision support systems: {C}urrent practice and continuing challenges},
 address = {Reading Mass. [etc.]},
 publisher = {Addison-Wesley Publ},
 isbn = {0-201-00193-4}
}

Hope that I haven't forget any neccessary information. Hope, someone of you have a hint where the problem may lies ... I have non any more.

share|improve this question
    
Do you get an error message? If yes please add it (or them) in your question. –  Kurt Dec 11 '12 at 5:28
    
thanx for helping, problem already solved :) –  user1787284 Dec 13 '12 at 2:39

1 Answer 1

up vote 2 down vote accepted

I don't know if this will work. It's like groping in the dark for me since I don't use LyX. But I think you have to change your bibliography processor to biber by clicking

Tools > Preferences > Output > LaTeX > Bibliography generation > Processor > Biber

If this does not work, you have to manually run biber on your file through your terminal.

cd to your working directory and run

biber myfile without the file extension. Then try ctrl-R again in LyX to compile and view your pdf.

Also, with biblatex, \bibliography is replaced with \addbibresource.

share|improve this answer
    
thanx :) the descriped way works for me –  user1787284 Dec 11 '12 at 15:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.