Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I tried lscape and pdflscape packages with spanish package. It doesn't work, only with english package. Are there any solution? I want to have the list of tables and the date in spanish, but I can't use those packages. This doesn't work for me:

\documentclass[12pt,a4paper]{article}
\title{Blah }
\usepackage{spanish}
\usepackage{pdflscape}
\begin{document}
\begin{landscape}
\begin{table}[h]
\caption{Matrix table}\verb+-+
\centering
\begin{tabular}{|p{35mm}|p{42mm}|p{42mm}|p{42mm}|p{42mm}|}
\hline \rowcolor{Gray}
\centering \textbf{TITLE} & \centering \textbf{TITLE} & \centering\textbf{TITLE} & \centering\textbf{TITLE} & {\centering\textbf{TITLE}}\\[0.5ex]
\hline
text & text & text & text & text\\
\hline
text & text & text & text & text\\
\hline
text & text & text & text & text\\
\hline
text & text & text & text & text\\
\hline
text & text & text & text & text\\
\hline
text & text & text & text & text\\
\hline
text & text & text & text & text\\
\hline
\end{tabular}
\end{table}
\end{landscape}
\end{document}

But, if I change the spanish package by english, it works. Thanks.

share|improve this question
    
Can you put together a tiny document that shows the problem you're having and add that to your question? See I've been asked to write a minimal example, what is that?. –  Alan Munn Dec 12 '12 at 4:16
    
Thanks, I did it. –  Isai Dec 12 '12 at 5:18

1 Answer 1

up vote 2 down vote accepted

The spanish package is not a package you load using \usepackage but instead is an option that you pass to the babel package. So the correct usage should be:

\usepackage[spanish]{babel}

NOT \usepackage{spanish} Your document should have put up the following error:

You have used an old interface to call babel.
You may expect compatibility problems wit other packages. 
You could proceed but don't complain if you run into errors.

One other comment about your code. I'm not sure what the \verb+-+ line is supposed to do for you. If you want to change the spacing or format of the caption, you should use the caption package.

share|improve this answer
    
Thanks for the solution, it was a headache. It works. About the \verb+-+, I used to solve the small space between table and its caption; but I find the solution with the caption package. Thanks for all! –  Isai Dec 12 '12 at 5:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.