Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Possible Duplicate:
Option clash for package xcolor

While trying to do this:\usepackage [ table ]{ xcolor } I get this error:

LaTeX Error: Option clash for package xcolor.

All the packages

\documentclass{article} % For LaTeX2e
\usepackage{nips12submit_e,times}
\usepackage[english]{babel}
\usepackage{graphicx}
\usepackage{graphics}
\usepackage{subfigure}
\usepackage{a4wide}
\usepackage[latin9]{inputenc}
\usepackage{fancyhdr}
\usepackage{amsmath}
\usepackage{amstext}
\usepackage{float}                  
\usepackage{listings}
\usepackage{url}            
\usepackage{multirow,tabularx}
\usepackage [ table ]{ xcolor }
\usepackage { hhline }

Any idea what is wrong ?

share|improve this question
    
@Ojwist Is the linked question one that answers your issue? If so, we will close this one as a duplicate. (Others: let Ojwist have a chance to answer before closing!) –  Joseph Wright Dec 16 '12 at 11:01
2  
The package eso-pic loads xcolor (without any option); in turn it's nips12submit_e that loads eso-pic, so you have to say \usepackage[table]{xcolor} before \usepackage{nips12submit_e}. Note that loading of a4wide is deprecated (and also dubious, as the nips package sets the page geometry), while subfigure is obsolete. –  egreg Dec 16 '12 at 11:02
add comment

marked as duplicate by Keks Dose, Martin Schröder, Mico, Claudio Fiandrino, Thorsten Dec 16 '12 at 12:16

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

up vote 6 down vote accepted

Probably one package loads xcolor with no or other options before line 16. Either try to move the line \usepackage [ table ]{ xcolor } up, or put »table« into the document options: \documentclass[table]{article}.

Though, I did not test.


Edit 1:

Question is a duplicate: Option clash for package xcolor . So despite my quick answer we have to close it.


Edit 2:

The package eso-pic loads xcolor (without any option); in turn it's nips12submit_e that loads eso-pic, so you have to say \usepackage[table]{xcolor} before \usepackage{nips12submit_e}.

-- says Egreg

share|improve this answer
    
Moving it up worked, will accept this as soon as the site allows me to –  Ojtwist Dec 16 '12 at 10:58
    
Keks, you could add what I said in my comment about locating where the call to xcolor should go. –  egreg Dec 16 '12 at 11:10
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.