Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Using the sans serif font Linux Biolinum, I set the Numbers option to Lining, in order to use normal numbers. This gives the following warning message (twice):

*************************************************
* fontspec warning: "icu-feature-not-exist-in-font"
* 
* OpenType feature 'Numbers=Lining' (+lnum) not available for font 'Linux
* Biolinum O/B' with script 'Latin' and language 'Default'.
*************************************************

The output nevertheless correctly prints normal lining numbers. What's going on here? Below a MWE with output.

\documentclass{article}
\usepackage{fontspec}
\setsansfont[Numbers = Lining]{Linux Biolinum O}

\begin{document}
Numbers: \textsf{0123456789}
\end{document}

enter image description here

share|improve this question
    
Maybe fontspec changing font for numbers? –  m0nhawk Dec 16 '12 at 16:07

2 Answers 2

up vote 9 down vote accepted

this works for me:

\documentclass{article}
\usepackage{fontspec}
\setmainfont[RawFeature=+onum]{Linux Libertine O}
\setsansfont[RawFeature=+lnum]{Linux Biolinum O}

\begin{document}
0123456789
Numbers: \textsf{0123456789}
\end{document}

enter image description here

share|improve this answer
    
According to the documentation of fontspec the option Numbers=Lining should set the font feature lnum, shouldn't it? And since this feature exists in Linux Biolinum O the warning is at least misleading. –  cgnieder Dec 16 '12 at 16:26
    
I want to set it because I normally use Numbers = OldStyle, so I want to see when I use lining numbers instead. That said - I have a suspicion that RawFeature=+lnum is ignored. I first copied your initial reply with the typo RawFeature=+lum, and it compiled without warnings, and printed lining numbers. –  Sverre Dec 16 '12 at 16:26
    
@cgnieder: I agree. The font clearly has lining numbers, so I'm puzzled why fontspec gives me this warning. It gives me no warning if I set Numbers = OldStyle. –  Sverre Dec 16 '12 at 16:28
    
@Sverre:ok, understood. I edited my example which works for oldstyle and lining numbers –  Herbert Dec 16 '12 at 16:32
1  
@Herbert I wonder if one should report this to the font developers? (I'm tempted to do so.) –  cgnieder Dec 17 '12 at 22:41

The bold variant of Linux Biolinum doesn't have the lnum feature (but does have lining numbers). This may explain why the warning is produced.

share|improve this answer
    
So does the 'B' in 'Linux Biolinum O/B' in the warning message stand for 'bold' then? I'm still somewhat puzzled what it means to not have the lnum feature, but nevertheless have lining numbers, but this might be a font specific thing I have no knowledge of. –  Sverre Dec 18 '12 at 17:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.