Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

Here is one of my bib entry

@InProceedings{linden,
author = {F. Van Der Linden, J. Bosch, E. Kamsties, K. K{\"a}ns{\"a}l{\"a} and Henk Obbink},
title = {Software Product Family Evaluation},
booktitle = {Software Product-Family Engineering, 5th International Workshop, PFE 2003},
address = {Siena, Italy},
month = {November},
year = {2004},
pages = {352-369}
}

and this is the output

[F. Van Der Linden and Obbink(2004)] F Van Der Linden EKKK J Bosch, Obbink H (2004)
Software product family evaluation. In: Software Product-Family Engineering, 5th International
Workshop, PFE 2003, Siena, Italy, pp 352{369

If you see it has just put EKKK JBosh etc instead of full E. Kamsties etc . Also the special chracters K{\"a} aren't read properly in bibliographies.

I have tried the IEEETran and even Springer latex templates to fix it but in vain.

I am using TexMaker and MikTex2.9 for making these files.

Urgent Help required

share|improve this question
2  
Try this for the author field: author={van der Linden, F. and Bosch, J. and Kamsties, K. and K{\"a}ns{\"a}l{\"a}, K. and Obbink, Henk} –  guillem Dec 17 '12 at 6:46
add comment

1 Answer 1

You've got stray commas and no "and"s in your bibtex

author = {F. Van Der Linden, J. Bosch, E. Kamsties, K. K{\"a}ns{\"a}l{\"a} and Henk Obbink},

should be

author = {Van Der Linden, F. and J. Bosch and E. Kamsties and 
          K. K{\"a}ns{\"a}l{\"a} and Henk Obbink},
share|improve this answer
    
If one uses F. Van Der Linden, then the given name is F. Van Der and the family name is Linden; the "comma form" should be used when the family name consists of more than one word, so I fixed your code. –  egreg Dec 17 '12 at 11:25
    
After these changes I get following error. When I do the second PDFLatex (pdflatex ->bibtex ->pdflatex->pdflatex) I got following error... ! Misplaced alignment tab character &. l.40 Software—Practice & Experience 41(8):883--897...which looks quite confusing as on line 40 is this command \institute –  Skipper07 Dec 17 '12 at 12:30
    
i guess your .bib file needs \& instead of & for that journal's entry. note that this is totally unrelated to the previous problem you were getting. –  wasteofspace Dec 17 '12 at 13:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.