TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Using latexdiff I have the problem, that by adding new \section, I get the following error by trying to run pdflatex.

! Argument of \UL@word has an extra }.
<inserted text> 
l.69 \subsection{\DIFadd{Some Text}}

Here you can see the redefined \section command...

{1}     % Structure level
{0mm}   % Indention
{2ex plus 1ex minus 1ex}            % Pre-Margin
{0.5ex plus 0.5ex minus 0.5ex}      % Post-Margin
{\chapterheadfont\Large\bfseries}   % Style
{2}     % Structure level
{0mm}   % Indention
{1.5ex plus 1ex minus 0.5ex}        % Pre-Margin
{0.3ex plus 0.3ex minus 0.3ex}      % Post-Margin
{\chapterheadfont\large\bfseries}   % Style

How can I fix the problem? It would work for me also to ignore the changed section names.

share|improve this question
Welcome to TeX.sx! We'd like to keep answers separate from questions, so you should write a separate answer instead of editing your answer into the question. Self-answers are perfectly admissible, and a well-written answer may earn you additional reputation. – lockstep Dec 18 '12 at 18:28
up vote 13 down vote accepted

(OPs answer, moved from the question.)

I thought it would be complexer, but I found a solution. Using --exclude-textcmd allows the ignoring of tags. It works now.

share|improve this answer
Where exactly did you put this text? – Veridian Feb 19 at 20:48
What does now mean? Version 1.1.1? – math Feb 23 at 13:41
@sphere: it is put as command line argument to latexdiff. – math Feb 23 at 13:41

It's difficult without an MWE, but I would assume that the difficulty is with hyperref, which tries to include underlined/crossed out text as hyperlink given that it is part of a chapter.

The solution is to use texorpdfstring, which tells hyperref to use plain text for the hyperlinks. I can't remember the exact commands that latexdiff definds, but try something like that:

% Redefine these commands for chapter/sections and change below

\RequirePackage[normalem]{ulem}% DIF PREAMBLE
\RequirePackage{color}\definecolor{RED}{rgb}{1,0,0}\definecolor{BLUE}{rgb}{0,0,1}%DIF PREAMBLE
\providecommand{\DIFadd}[1]{{\protect\textcolor{blue}{\hwave{#1}}}}% DIF PREAMBLE
\providecommand{\DIFdel}[1]{{\protect\textcolor{red}{\hsout{#1}}}}% DIF PREAMBLE
share|improve this answer
I've tried your solution, but it doesn't work. I get the same errors like before. – aphex Dec 18 '12 at 22:51
@aphex Then please provide an MWE – Jörg Dec 19 '12 at 9:16
@Jörg I seem to be suffering from the same issue. In my document i have a section "Conclusions". When i set this as a comment my latexdiff file compiles as normal. However if i have this as a section, the same error appears: Argument of \UL@word has an extra }. <inserted text> \par l.1411 \DIFaddbegin \section{\DIFadd{Conclusion}} – wierts Nov 22 '13 at 14:28

I had the same problem on a very large document, and based on Jörg suggestion, I just removed the call to hyperref package (and \hypersetup ) in the difference tex file and it compiled fine. Just a fast workaround.

share|improve this answer
This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – Henri Menke Nov 25 '15 at 12:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.