Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I have met warning:"Package hyperref Warning: Composite letter `\textdotbelow+u'" when i use this code to create a bookmark

\pdfbookmark{\contentsname}{Contents}

I don't know the reason for this warning, how to avoid and fix the warning.

share|improve this question
2  
What language are you using? –  egreg Dec 20 '12 at 13:52
    
@egreg :Sorry, i don't understand the meaning of your question. –  phuong Dec 21 '12 at 7:05
    
I can only conjecture that you're writing your document in Vietnamese. Please, add the first lines of your document, where you declare the language used (something like in my example code below). –  egreg Dec 21 '12 at 7:35
add comment

2 Answers

Pass the unicode option to hyperref:

\documentclass{article}
\usepackage[utf8]{vietnam}
\usepackage[unicode]{hyperref}
\begin{document}
\pdfbookmark{\contentsname}{Contents}
\tableofcontents

\section{a}
\end{document}

Without the option I indeed get the warning

Package hyperref Warning: Composite letter `\textdotbelow+u'
(hyperref)                not defined in PD1 encoding,
(hyperref)                removing `\textdotbelow' on input line 5.

The warning disappears with that option. This should be independent of the input encoding chosen; I've tried with viscii, tcvn, vps, and utf8x

share|improve this answer
add comment

use

\pdfbookmark{\texorpdfstring{Contents}{\contentsname}}{Contents}

For Contents In \textorpdfstring you can use any translation without special characters which are not possible in the bookmarks of a pdf file, like your u with a underdot

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.