Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am trying to use \mathbb. It seems that this command requires \usepackage{amsfont}. But as soon as I use this package, my MikTeX 2.9 installation complains that it doesn't find amsfont.sty. So where is it and how do I install it?

Here's the "formula" that I try to process:

\documentclass{article}
\usepackage{amstext} 
\usepackage{amsmath} 
\usepackage{amsfont} 
    \pagestyle{empty}

    \begin{document}
     $   \mathbb{R}^n   $
    \end{document}

I should also note that there is a file with the name amsfonts.sty under MiKTeX-2.9\tex\latex\amsfonts (note the plural, amsfonts.sty vs amsfont.sty).

The complete error message is:

This is pdfTeX, Version 3.1415926-2.3-1.40.12 (MiKTeX 2.9)
entering extended mode
(c:/temp/formula.tex
LaTeX2e <2011/06/27>
Babel <v3.8m> and hyphenation patterns for english, afrikaans, ancientgreek, ar
abic, armenian, assamese, basque, bengali, bokmal, bulgarian, catalan, coptic,
croatian, czech, danish, dutch, esperanto, estonian, farsi, finnish, french, ga
lician, german, german-x-2009-06-19, greek, gujarati, hindi, hungarian, iceland
ic, indonesian, interlingua, irish, italian, kannada, kurmanji, lao, latin, lat
vian, lithuanian, malayalam, marathi, mongolian, mongolianlmc, monogreek, ngerm
an, ngerman-x-2009-06-19, nynorsk, oriya, panjabi, pinyin, polish, portuguese,
romanian, russian, sanskrit, serbian, slovak, slovenian, spanish, swedish, swis
sgerman, tamil, telugu, turkish, turkmen, ukenglish, ukrainian, uppersorbian, u
senglishmax, welsh, loaded.
(C:\tools\MiKTeX-2.9\tex\latex\base\article.cls
Document Class: article 2007/10/19 v1.4h Standard LaTeX document class
(C:\tools\MiKTeX-2.9\tex\latex\base\size10.clo))
(C:\tools\MiKTeX-2.9\tex\latex\ams\math\amstext.sty
(C:\tools\MiKTeX-2.9\tex\latex\ams\math\amsgen.sty))
(C:\tools\MiKTeX-2.9\tex\latex\ams\math\amsmath.sty
For additional information on amsmath, use the `?' option.
(C:\tools\MiKTeX-2.9\tex\latex\ams\math\amsbsy.sty)
(C:\tools\MiKTeX-2.9\tex\latex\ams\math\amsopn.sty))
share|improve this question

closed as too localized by egreg, cgnieder, Andrew Swann, Stefan Kottwitz Dec 21 '12 at 14:33

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Welcome to TeX.SE! –  Vivi Dec 21 '12 at 9:29
2  
where did you see the name amsfont.sty or \usepackage{amsfont}? that's wrong; amsfonts is the correct name. if it's in any ams documentation, then i can get it fixed, and would like to do so. –  barbara beeton Dec 21 '12 at 13:30

1 Answer 1

up vote 3 down vote accepted

Try amsfonts, with an s at the end.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.