Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I'm a LaTeX user working through some ConTeXt tutorials, and hit a brick wall pretty early. It makes me wonder if something is wrong with my setup, or if I'm not understanding something pretty fundamental, or if ConTeXt is a bit more brittle than I had hoped. I'm using MacTeX-2012.

I'm getting errors when using both a formula and an enumeration with the letter option. Leaving out the letter option, this works great:

\defineenumeration[guess][location=left]
\starttext
  \startformula
    x = no error
  \stopformula
  \guess This is just a guess.

\stoptext

The following, however, causes texexec to fail with Undefined control sequence on \startformula and \stopformula:

\defineenumeration[guess][location=left, letter=it]
\starttext
  \startformula
    x = error
  \stopformula
  \guess This is just a guess.

\stoptext

Taking out the formula removes the error, so the enumeration with the letter=it option is working fine on its own.

In testing this, I discovered (to my surprise) that commenting out the letter option gives the same error:

\defineenumeration[guess][location=left] %, letter=it]
\starttext
  \startformula
    x = error
  \stopformula
  \guess This is just a guess.

\stoptext

But taking out the = sign fixes it. No error when running:

\defineenumeration[guess][location=left] %, letter it]
\starttext
  \startformula
    x = no error
  \stopformula
  \guess This is just a guess.

\stoptext

However, it's not just the equals sign, as this works without error:

\defineenumeration[guess][location=left] %, bar=baz]
\starttext
  \startformula
    x = no error
  \stopformula
  \guess This is just a guess.

\stoptext

I am very confused. Am I doing something wrong?

share|improve this question
1  
Why are using MkII? If you don't have any particular reason not to use MkIV, i.e. context instead of texexec, then imho it's better to use MkIV. (MkII is no longer being developed, so in case of bugs/feature requests you're basically on your own.) –  mbork Dec 21 '12 at 17:08
2  
I have no trouble running your example using context with ConTeXt standalone. ConTeXt standalone is very quick and easy to install and a lot more up-to-date, though you should use MkIV as @mbork says. Try that and see if it fixes your problems. –  Daniel Lyons Dec 21 '12 at 17:10
    
Wow... using context worked perfectly. I've read tons of documentation that praise texexec for running as many times as necessary to get cross references and citations right. Am I reading out-of-date documentation? Does context do this as well? If someone puts this as an answer I'll accept it. –  Sam Britt Dec 21 '12 at 17:14
    
Yes, context will do that as well. I suspect what you're reading is out-of-date. I rely on this site and the ConTeXt wiki for all my info. :) –  Daniel Lyons Dec 21 '12 at 17:42
    
As a personal choice, I prefer to use \startguess ... \stopguess rather than \guess ... \par. The latter can sometimes fail with a weird error message if the \par (empty line in the end) in missing. –  Aditya Dec 23 '12 at 3:16

1 Answer 1

up vote 4 down vote accepted

For some reason the code you provided makes ConTeXt switch to the dutch interface (I have no clue why). In the dutch interface the command \startformula is not defined and hence you get an error. You can process the file with

texexec --interface=en file.tex

This forces ConTeXt to use MkII with the English interface and the file is processed.

However, as already pointed out in the comments you should probably better use ConTeXt MkIV, which uses the command context instead of texexec. You will get full Unicode support and much easier font handling.

BTW: I have no clue what the letter=it option is supposed to do. Where did you find it documented?

share|improve this answer
    
Thanks! I was using the "LaTeX in proper ConTeXt" tutorial from berenddeboer.net/tex. Using letter=it is supposed to make the text italic---and it works, in Dutch mode. And it must be the problem: using style=italic (which I got from the wiki) causes texexec to run in English, and I get no errors. Weird. Will use ConTeXt MkIV from now on, and stick to more official documentation. –  Sam Britt Dec 21 '12 at 18:58
    
I think style=it instead will do the trick in MkIV. –  Daniel Lyons Dec 21 '12 at 20:04
    
If it doesn't, try headstyle=it. There's a reference on the wiki. –  Daniel Lyons Dec 21 '12 at 20:12
    
@DanielLyons So it and italic are the same? There's no mention of either on the page you linked to, and that's for descriptions, not enumerations. Multiple ways to do the same thing, incomplete documentation, weird bugs when switching to MkIV and/or Standalone, fourteen different table environments (with no simple booktabs)... I have to say learning ConTeXt has not exactly been a pleasant experience. –  Sam Britt Dec 24 '12 at 13:53
    
@SamBritt \it is the low-level switch to select the italic font. italic is defined as \definealternativestyle[italic][\it][], that enables you to use it as a style: style=italic or as a font switch: {\italic Some text} –  Marco Dec 24 '12 at 15:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.