Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I recently switched from a windows box to linux mint + cinnamon. The files I normally run on windows will not print the references. I'm using texstudio with tex live. Here's a MWE:

\documentclass[leavefloats]{apa6e}
\usepackage[american]{babel}
\usepackage[style=apa,backend=biber,bibencoding=latin1]{biblatex}
\addbibresource{testb.bib}
\DeclareLanguageMapping{american}{american-apa}
\usepackage{hyperref}
\defbibheading{bibliography}{%
\section{\normalfont\refname}}

\title{title}
\shorttitle{ti}
\author{me}
\authornote{note}
\abstract{abs}
\date{\today} 
\begin{document}
\maketitle

MWE

\parencite{Mcvee2005}

\printbibliography

\end{document}

The bib file is:

@ARTICLE{Mcvee2005,
  author = {Mcvee, Mary B. and Dunsmore, Kailonnie and Gavelek, James R.},
  title = {{Schema theory revisited}},
  journal = {Review of Educational Research},
  year = {2005},
  volume = {75},
  pages = {531-566}
}

Here's a link to the log file: http://dl.dropbox.com/u/61803503/test.log

How can I get the references to print using the new linux environment with tex live.

Note:
Running the following from the command line:

pdftex test.tex
bibtex test.aux

results in:

.
tyler@trinker ~/Desktop/MWE $ bibtex  test.aux
This is BibTeX, Version 0.99d (TeX Live 2012/Debian)
The top-level auxiliary file: test.aux
I found no \citation commands---while reading file test.aux
I found no \bibdata command---while reading file test.aux
I found no \bibstyle command---while reading file test.aux
share|improve this question

migrated from meta.tex.stackexchange.com Dec 23 '12 at 15:39

This question came from our discussion, support, and feature requests site for users of TeX, LaTeX, ConTeXt, and related typesetting systems.

1  
You have backend=biber, so you need to run biber and not bibtex –  egreg Dec 23 '12 at 15:49

1 Answer 1

up vote 4 down vote accepted

Configure TeXStudio to run biber instead of bibtex if you want to have biber as your backend.

Click

Options > Configure TeXStudio > Build > Default Bibliography > Biber

Otherwise, replace backend=biber option to backend=bibtex. As mentioned in comment, when using command line/terminal, you have to run biber test when using the biber backend. (Note that the omission of the file extension.)

share|improve this answer
    
Just wanted to add this for future searchers. This is what I had to do exactly: Options > Configure TeXStudio > Build > Commands > biber %.bcf using texstudio 2.3. Thanks a ton hpesoj626. –  Tyler Rinker Dec 23 '12 at 18:55
1  
With TeXstudio 2.5.1 (SVN 3484), you don't have to specify %.bcf. Also, pressing F6 will automatically run every command you need to compile your document (i.e., it will automatically detect whether you need to do makeindex and run that for you). –  hpesoj626 Dec 23 '12 at 23:05
    
Thanks good tip. I downloaded the newest version (2.5.1) and your directions are spot on. –  Tyler Rinker Dec 24 '12 at 3:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.