Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using biblatex for writing my thesis and it works generally fine. Now I want to put back references to my bibliography. However, after putting the option into the preamble, the back references only appear in the normal bibliography but not in the list of the shorthands. Does anyone know how to make the shorthand list including the back references? Here is a mini example (compiled with lualatex, but I think the result is the same as with latex):

\documentclass{memoir}
\usepackage{filecontents}
\begin{filecontents*}{mybib.bib}

@book{Abook,
author = {First Author and The Second Author},
title = {The Longtitle and not the Shorttitle},
shorthand = {LnS},
publisher = {The Publisher},
address =  {Address},
year = {1965}}

@article{Aarticle,
author = {Article Author},
journal = {Journal Title},
pages = {113-126},
title = {Title of the Article},
volume = {65},
year = {1968}}

\end{filecontents*}
\usepackage[hidelinks]{hyperref}
\usepackage[style=philosophy-modern,backref=true,hyperref=true,language=auto,autocite=inline]{biblatex}

\defbibcheck{noshorthand}{%
\iffieldundef{shorthand}{}{\skipentry}}

\bibliography{mybib}
\bibintoc
\usepackage[ngerman,english]{babel}%english names of sections
\usepackage[babel,english=british]{csquotes}

\begin{document}
Backreference?
\cite{Abook}
\cite{Aarticle}
\printshorthands
\printbibliography[check=noshorthand]
\end{document}

Result:

enter image description here

enter image description here

enter image description here

share|improve this question
add comment

1 Answer 1

up vote 5 down vote accepted
+50

Modifying the shorthands bibliography driver seems to do the trick.

\documentclass{memoir}
\usepackage{filecontents}
\begin{filecontents*}{\jobname.bib}

@book{Abook,
author = {First Author and The Second Author},
title = {The Longtitle and not the Shorttitle},
shorthand = {LnS},
publisher = {The Publisher},
address =  {Address},
year = {1965}}

@article{Aarticle,
author = {Article Author},
journal = {Journal Title},
pages = {113-126},
title = {Title of the Article},
volume = {65},
year = {1968}}

\end{filecontents*}
\usepackage[hidelinks]{hyperref}
\usepackage[style=philosophy-modern,backref=true,hyperref=true,language=auto,autocite=inline]{biblatex}

\defbibcheck{noshorthand}{%
\iffieldundef{shorthand}{}{\skipentry}}

\addbibresource{\jobname.bib}
\bibintoc
\usepackage[ngerman,english]{babel}%english names of sections
\usepackage[babel,english=british]{csquotes}

\DeclareBibliographyDriver{shorthands}{%
  \usedriver
    {\DeclareNameAlias{sortname}{default}}
    {\thefield{entrytype}}%
  \setunit{\bibpagerefpunct}\newblock% NEW
  \usebibmacro{pageref}% NEW
  \finentry}

\begin{document}
Backreference?
\cite{Abook}
\cite{Aarticle}
\printshorthands
\printbibliography[check=noshorthand]
\end{document}

enter image description here

share|improve this answer
2  
+1 This works because \usedriver locally sets the bibindex and pageref bibliography macros to \@empty. –  Audrey Dec 28 '12 at 1:48
    
Thank you lockstep, thank you Audrey! The solution provided by lockstep is working fine until now. It seems that biblatex has to provide an option for the backrefs in the list of shorthands. –  insight Dec 28 '12 at 22:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.