Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am having some trouble with my footnotes becoming coloured in certain situations. In particular, I am wanting to use memoir's \paragraphfootnotes, but all the footnotes for a page become coloured if coloured text crosses a page boundary. I am using pdfLaTeX.

\documentclass{memoir}
\usepackage{xcolor}

\paragraphfootnotes

\begin{document}

This\footnote{a footnote} is\footnote{another footnote} \textcolor{red}{some red
\newpage text} with a page break.

\end{document}

If I don't use \paragraphfootnotes (i.e. if I just use \plainfootnotes) then everything works properly, but that is not an option when I sometimes have 50+ very short footnotes on a single page. Is there some colour-resetting code missing from memoir's implementation of \paragraphfootnotes? How can I fix this?

Note: This problem also appears if I use \twocolumnfootnotes.

share|improve this question
    
Noted, though I have no idea what the problem is –  daleif Dec 27 '12 at 11:39

2 Answers 2

This can be fixed by loading the bigfoot package. Quoting from The bigfoot bundle for critical editions, p. 199--200:

So what are the features that bigfoot provides?

[...]

  • When footnotes are broken across pages, the color stack is maintained properly. Color is handled in LaTeX with the help of specials that switch the color (and, in the case of dvips, restoring it afterwards with the help of a color stack). Restarting the footnote on the next page with the proper color is something that has never worked in LaTeX. Now it simply does.

EDIT: memoir's \paragraphfoototes must be replaced with bigfoot's \DeclareNewFootnote[para]{default}, which will result in different spacing between footnotes.

\documentclass{memoir}

\usepackage{xcolor}

\usepackage{bigfoot}
\DeclareNewFootnote[para]{default}

\begin{document}

This\footnote{a footnote} is\footnote{another footnote} \textcolor{red}{some red
\newpage text} with a page break.

\end{document}
share|improve this answer
    
Unfortunately, I can't seem to get this to work. It ignores \paragraphfootnotes and other commands, so it's actually just like using \plainfootnotes from memoir which already works fine. –  codebeard Dec 28 '12 at 8:15
    
From the very minimal documentation, I tried using \DeclareNewFootnote[para]{default}[alph] but that choked because I sometimes have more than 26 footnotes per page. I was then able to fix this with \renewcommand*{\thefootnotedefault}{\textbf{\textrm{\alphalph{\value{footnotede‌​fault}}}}} and \MakePerPage{footnotedefault} but the footnote spacing within the paragraph footnote blocks is all wrong (it will often just put one footnote when previously 3 would have been). Maybe I just need one or two other commands, but I'm out of ideas. –  codebeard Dec 28 '12 at 8:29
    
@codebeard I updated my answer. The spacing seems to be different, but not "all wrong" with bigfoot. Can you give an example with clearly improper spacing (maybe in a follow-up question, as this would be a different issue from wrong colouring)? –  lockstep Dec 28 '12 at 10:40
    
You're right it's not “all wrong” per se, but it's significantly different. Namely, the indentation is large and the para* option from manyfoot doesn't seem to go through properly (which is supposed to stop the indentation). \SetFootnoteHook{} doesn't seem to help either. The main issue, though, is that footnotes will start on a new line if there's not enough space for them to finish on the previous line. This wastes a lot of space and is nothing like memoir's paragraph footnotes. –  codebeard Dec 29 '12 at 1:47
    
This is for a volunteer project to typeset a new Bible translation. Here's a screenshot of what I had with \paragraphfootnotes: The full source is publicly available at github.com/kieranclancy/isv_tex and you can see the footnote options I was trying to use here. –  codebeard Dec 29 '12 at 2:07

Here is a slightly odd workaround

\makeatletter
\renewcommand{\footnoterule}{%
  \kern-3\p@
  \normalcolor\hrule width .4\columnwidth
  \kern 2.6\p@}
\makeatother

I added the \normalcolor. Think I'll add that to the next version.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.