TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After updating the texlive 2012 in Ubuntu 12.04 by

# tlmgr update --all

I found pdflatex (within Texmaker) cannot compile a TeX file with the Libertine font

\usepackage{libertine}                        % libertine

However, in Terminal the tex file can be compiled by the command

$ pdflatex  thesis.tex

I even uninstalled and reinstalled Texmaker, the problem still persists.

share|improve this question
In what sense "Texmaker" cannot compile? What's the error? – egreg Dec 27 '12 at 14:11
This is the error info: pdfTeX error: pdflatex (file fxlb-xl-8x): Font fxlb-xl-8x at 720 not found ==> Fatal error occurred, no output PDF file produced! – KOF Dec 27 '12 at 14:20
I suspect that Texmaker is using the TeX Live/Debian distribution, rather than the "vanilla" that's used when you compile from the shell. Can you add the first lines of the log file obtained when you compile from Texmaker? – egreg Dec 27 '12 at 14:25
You are right. LOG FILE : This is pdfTeX, Version 3.1415926-2.4-1.40.13 (TeX Live 2012/Debian) (format=pdflatex 2012.11.19) 27 DEC 2012 15:30 entering extended mode – KOF Dec 27 '12 at 14:31
Since you appear to be using tlmgr, you have installed also the "vanilla" TeX Live; so this seems a path problem; check in Texmaker's preferences for how the pdflatex command is called. – egreg Dec 27 '12 at 14:33
up vote 3 down vote accepted

This is actually a path problem.

If you have installed the "vanilla" TeXLive, it is not enough to add the new PATH in your.profile file (or any configuration fill used by your shell like cshrc or .zshrc...) because this configuration file is not used by your graphic environment (gnome, kde, xfce...).

For graphic environment, there is no such file for each user (omission in freedesktop?)!

In Debian/Ubuntu distribution, you can add the new PATH in the /etc/environment file (via sudo). Replace:




(where /usr/local/texlive/2012/bin/x86_64-linux is the TeXLive path on x86_64 architecture. On i386 architecture, choose /usr/local/texlive/2012/bin/i386-linux.)

share|improve this answer
Bashrc setting: export TEXMFDIST=/usr/local/texlive/2012/texmf-dist export, PATH=/usr/local/texlive/2012/bin/i386-linux:$PATH, The path was set since Texlive 2012 being installed. Weird thing is that it works in my Laptop but not in my office PC. (Both computers have same OS - Ubuntu 12.04) – KOF Dec 30 '12 at 13:55
@KOF Your bashrc settings is not used by Texmaker! TexMaker uses it if it is launched from a terminal... – Paul Gaborit Dec 30 '12 at 14:42
@KOF Launch texmaker from a terminal with the correct PATH and try again (xelatex calls implicitly dvipdfmx and uses PATH to found it. So, your PATH must be correct.) – Paul Gaborit Dec 30 '12 at 22:00

the names of the files for Libertine changed with the latest update. But your installed TeX-distribution always searches in the Ubuntu configuration and not in the TUG-TeXLive one. You should delete the Ubuntu TeXLive and then install the dummy package


and then setting the pathes as shown in http://archiv.dante.de/~herbert/Ubuntu/zzz-texlive.sh

share|improve this answer
Well, it's old version of texlive 2011~ – KOF Dec 29 '12 at 21:22
do you mean the deb file? – Herbert Dec 29 '12 at 21:26
Is there such Ubuntu version of texlive 2012? – KOF Dec 29 '12 at 22:27
I think so, but it has no TeXLive manager for daily updates! This is only possible with the TUG TeXLive – Herbert Dec 29 '12 at 22:29
That's what i have installed from TUG – KOF Dec 30 '12 at 9:26

I had similar problems when using xelatex from TexLive 2012 in TexMaker. I believe it's a $PATH issue in that TexMaker doesn't know where to find the correct commands, even when using the explicit path. I never solved the problem but I completely removed TexLive 2012 and installed the Ubuntu version via apt. After that xelatex docs compile normally.

Addendum: Just looked through my email and TexMaker support confirmed it's a path problem. He didn't say how to fix it, just that it's a path problem.


share|improve this answer
The path of pdflatex shown in Terminal is: $ which pdflatex: /usr/local/texlive/2012/bin/i386-linux/pdflatex. While in Texmaker it's like: pdflatex -synctex=1 -interaction=nonstopmode %.tex. Can I set this corresponding to the system path? – KOF Dec 27 '12 at 15:56
Problem solved by $ updmap as user (not as root)! – KOF Dec 27 '12 at 22:14

I found a universal solution for this issue:

Just delete all of the texlive 2012 related files/folders in your Home folder, and completely remove Texmaker.

Then reinstall texmaker and the installation will automatically search for the right path for fonts and execute files.

share|improve this answer
and TeXmaker depends to Ubuntus TeXLive and will install it again except when you install TeXmaker from the sources. – Herbert Jan 1 '13 at 21:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.