Take the 2-minute tour ×
TeX - LaTeX Stack Exchange is a question and answer site for users of TeX, LaTeX, ConTeXt, and related typesetting systems. It's 100% free, no registration required.

I am using Ubuntu as OS. When I try to run a tex code, I receive this error from Textmaker :

! Font T1/ppl/m/n/12=pplr8t at 12.0pt not loadable: Metric (TFM) file not found
! Font T1/ppl/m/n/24.88=pplr8t at 24.88pt not loadable: Metric (TFM) file not found.
! Font \T1/ppl/b/n/24.88=nullfont not loadable: Metric (TFM) file not found.
...

It seems to be a Font problem, but I have no idea on how to fix it. Thank you in advance for your help. Please note that the same code could be run perfectly before. I tried to reinstall texmaker but it didn't helped.

EDIT Please find on below the Packages used :

\documentclass[12pt,a4paper]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8x]{inputenc}
\usepackage{ucs}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{mathrsfs}
\usepackage{fancybox}
share|improve this question
1  
Welcome to tex.stackexchange! Is it it possible to edit your answer and add some code that illustrates your problem? Thank you! –  Thanos Dec 27 '12 at 16:08
    
Thank you for this warm welcome! Considering the code, I doubt that it will be useful, considering the errors given. However I will give you the packages I am loading. –  user23710 Dec 27 '12 at 16:13
1  
@ Sigur: Thank you very much, it's solved now! –  user23710 Dec 27 '12 at 16:18

1 Answer 1

up vote 15 down vote accepted

As you tested, this solves the problem.

  sudo apt-get install texlive-fonts-recommended
  sudo apt-get install texlive-fonts-extra

Some expert could say if both packages are necessary or only one does the job.

share|improve this answer
1  
I've verified that sudo apt-get install texlive-fonts-recommended Is sufficient to get ppl. I can't speak directly to your code though. –  Luke Schlather Apr 1 '13 at 16:00
1  
The first line does the job. Thanks! –  Magister Halderian Oct 7 at 10:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.